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Speed: Forward Only Time Filter

Time Remap Filter

Preset Locations: Filters



Alpha channel
An alpha channel is a part of the image data that describes each pixel’s level of
opacity or translucency. Contrast that with the other data, which describes light and
color. Many people think of an alpha channel as a transparency mask. However,
that can lead one to think of it as rather binary - opaque or transparent - whereas
most often an alpha channel has at least 256 levels.

Aspect ratio
Aspect ratio is how the width of a rectangle compares with its height. In other
words, wide or tall, and by how much? This is typically expressed as a fraction of
width over height. For example, if a rectangle is twice as wide as it is high, we can
say it i has a 2:1 aspect ratio. This can get complicated in video where pixels
themselves can have an aspect ratio that is distinct from the display aspect ratio.
For example, SD NTSC video has a resolution of 720x480 but can be either 4:3 or
16:9 display aspect ratio neither of which are square pixels! Modern video
standards such as ATSC and UHD avoid using non-square pixels such that the
common HD resolution 1920x1080 reduces mathematically to 16:9, which is also
the most common video aspect ratio in use today.

B frames
A Bi-directional predicted (B) frame is a frame of a video that uses the motion-
compensated differences between itself and both the preceding and following
frames to specify its content. By doing so they use fewer bits to store the
information than both I-frames and P-frames.

Bitrate
Bitrate refers to the quantity of data (or number of bits) per unit of time. Most digital
audio and video formats use compression to save space, and the compression
ratio will vary. For instance, a clear blue sky contains relatively little information and
will generally compress well, while a more complex scene will compress less well.
Bitrate is also affected by other factors such as the compression algorithm used
and the quality level chosen.

Clip
In video editing, a clip refers to a segment of video footage or audio that is a
distinct unit within the overall project. Clips can vary in length and content, ranging
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from just a few frames to several minutes long. They are the building blocks of a
video project and can be manipulated, arranged, and edited together to create the
final product. Clips can be sourced from various recordings, imported media files,
or generated within Shotcut itself in “Open Other…” (ex.: Color clip, Text clip,
Animation (Glaxnimate) clip, etc…). Additionally, clips may contain both video and
audio components, or they can be exclusively video or audio depending on the
nature of the project. Clips are primarily used in the Timeline for editing but can
also be utilized in the Source panel and in the Playlist for previewing and
organization.

Codec
A codec comprises two components, an encoder and a decoder, hence the name.
Examples of video codecs are H.264, H.265, VP9 etc.. Codecs use various
technologies to compress data. The compression can either be lossless, in which
case decoding the data will produce exactly the same data that was encoded, or
lossy, in which case decoding the data will lose some of the data that was encoded.
The higher the compression the more data is lost. In general the use of lossless
codecs result in much larger files than lossy ones. Some codecs are more efficient
than others in the amount of data they need to produce videos of equivalent quality
e.g. H.265 produces smaller files than H.264 at equivalent quality; however, the
more complex methods needed to do this usually mean that they take longer to
encode and decode the video.

See also Prologue | Codec Wiki

Colorspace
Color space is about how color and light is represented especially numerically. In
video and computer images, the two most popular systems of organization are
RGB and YUV (or Y’CbCr). This is a complicated subject area; you can read more
on Wikipedia.

Deinterlacer
A deinterlacer is an algorithm to convert interlaced video to progressive scan. See
below for definitions on these two terms.

Field order
Interlace video consists of two fields per frame. This term describes which field
appears before the other in storage and/or display.

GOP
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A GOP, or Group Of Pictures, specifies the order in which intra-frames (I-frames)
and inter-frames (B- and P-frames) are arranged. The GOP is a collection of
successive frames within a coded video stream. Each coded video stream consists
of successive GOPs, from which the visible frames are generated. Encountering a
new GOP in a compressed video stream means that the decoder doesn’t need any
previous frames in order to decode the following ones, and allows fast seeking
through the video. The GOP structure is often referred by two numbers, for
example, M=3, N=12. The first number tells the distance between two anchor
frames (I or P). The second one tells the distance between two full images (I-
frames): it is the GOP size. For the example M=3, N=12, the GOP structure is
IBBPBBPBBPBBI.

GUI
GUI is short for Graphical User Interface. As opposed to a Command Line Interface
(CLI), which enables users to interface with application only by typing commands, a
GUI consists of various widgets (graphical elements such as buttons, scrollbars,
color-pallettes etc.) that enable the user to control the application and receive
feedback to enable them to make decisions on how next to proceed.

I frame
An Intra-coded (I) frame, also called a keyframe (not to be confused with keyframes
used for animating filter parameters), is a frame of a video that is coded
independently of all other frames. Consequently they use the more bits than B-
frames ans P-frames to store the information. Each GOP begins (in decoding
order) with this type of frame.

Interlace
Interlace is a simple form of video compression that uses two half vertical
resolution frames to represent a full frame. Basically, you can double the refresh
rate for the same data rate. Each half vertical resolution image is called a field.
Typically the fields are interleaved in storage and then displayed one after the other
on play back by skipping every other line.

Interpolation
Interpolation is the computation of values based on neighboring values. With
respect to Settings, it easiest to think of this as the quality level when changing the
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size of an image. Interpolation is also a term used for animating parameters in
Keyframes.

Keyframe
A keyframe defines a specific value or set of values at a specific point in time. The
term is used when talking about animating parameter values in Keyframes. It is
also used in temporal video compression (so-called delta or P- or B-frames).

Metadata
Metadata is data about another data. In the context of multimedia, the media data
(audio/video) is the core data, and all other data in the file is metadata. There can
be metadata about the media attributes such as resolution or number of audio
channels. And there can be metadata about the context of the media file such as its
creator, creation data, title, etc.

MLT
MLT is another open source software project that is the engine of Shotcut. Shotcut
is primarily the user interface running on top of this engine. This engine provides
some effects of its own, but it also uses other libraries such as FFmpeg, Qt,
WebKit, frei0r, lads, etc.

P frame
A Predicted (P) frame is a frame of a video that uses the motion-compensated
differences between itself and the preceding frame to specify its content. By doing
so they use fewer bits to store the information than I-frames, but more than B-
frames.

Progressive
In video, this refers to a scan mode where (“scan” refers to old tube-based TV
technology where a cathode ray draws video by drawing lines) each frame of video
is a whole picture from a single point in time. This is the opposite of interlace.

Resolution
Display Resolution is the actual pixel size of video and images. Example sizes:
3840x2160 (4k), 1920x1080 (HD), 1280x720 (HD), 720 × 480 (SD), 1080x1380
(Vertical)

https://mltframework.org/
https://en.wikipedia.org/wiki/Display_resolution


Ripple
Ripple means that an operation can affect the clips on the timeline that are later or
after the clip being changed. For example, a ripple delete not only removes the clip
but also the space it occupies. This requires changing the start time of all of the
following clips.

Sample rate
Sample rate refers to how many times per second a sample is taken of the audio or
video. For instance, in the real analog world, a car driving down the street moves
continuously, but a video of that consists of individual snapshots taken at regular
intervals. If you could slow down time and watch the car, the real world car would
still move smoothly; however, the video would show the car jumping from one
position to another. Common sample rates for video include 24, 25, 30, and 60
frames per second; common sample rates for audio include 44,100 and 48,000
samples per second.

Scrubbing
Scrubbing is seeking by clicking some object and dragging it. Typically this is the
play head in the player or timeline. But it can also refer to simply rewind and fast
forward playback through media.

Skimming
Skimming is seeking based on the horizontal position of the mouse over the video
image or timeline. You press and hold the Shift  + Alt  keys in Shotcut to
enable skimming.

Snapping
Snapping is a setting on the timeline. Aids in sliding two clips together on the same
track with no gap in between them.

Scan mode



Scan mode indicates whether video is progressive or interlaced - see related
definitions above.

Threads
Threads are a software programming mechanism to let multiple things occur at the
same time. Most CPUs now consist of multiple execution units typically called
“cores.” Often, these cores support a CPU-based “thread,” which you can think of
as a light core (not completely parallel). While it is important that your operating
system let multiple things run at the same time to use these CPU cores and
threads, it also important that Shotcut run things (i.e. parallel processing) at the
same time because media decompression, processing, and compression is very
computationally heavy. You can learn more about how Shotcut uses multiple cores
and threads in the FAQ.

Timecode
Timecode is a way to represent time numerically. Shotcut uses a standard called
SMPTE from the Society of Motion Picture and Television Engineers. It is a display
of the running time of video that is frame-accurate yet easier for humans to
understand than pure frame count. It shows hours, minutes, seconds, and frames
in the format HH:MM:SS:FF. On many video modes that use a non-integer frame
rate (e.g. 29.970030 or 30000/1001 fps), the semicolon ( ; ) is the delimiter
between seconds and frames to indicate that it is using drop-frame timecode. Drop-
frame is a technique to make the timecode follow the real time over long durations.
For 30000/1001 fps, drop-frame subtracts two frames every minute except every
tenth minute.

UI
UI is short for User Interface. This is the mechanism whereby users interact with
the application (Shotcut). The goal of this interaction is to allow effective operation
and control of the application from the human end, while the application
concurrently feeds back information that aids the user’s decision-making process.

VUI
VUI is short for Visual User Interface, In the context of Shotcut this is an interface
that appears in the preview area of the screen when certain filters, like the Text:
Rich filter, or the Size, Position & Rotate filter are active. The VUI enables users to
manipulate the parameters by dragging handles and/or typing directly in the preset
window rather than changing the parameters manually in the filters panel.

XML

https://shotcut.org/FAQ/#how-does-shotcut-use-multiple-cpu-cores-and-threads


XML is a text format that is designed to be both human and machine readable and
writable. It is standardize, structured, and extensible - the X in eXtensible Markup
Language. There are many dialects of XML, and when one video editor says it
reads “XML” it does not mean it can read the XML that another video editor can
export. They need to be the same kind of XML. Shotcut reads and writes MLT XML,
but at this time it can only fully understand the MLT XML that it writes.



Shotcut supports Windows, macOS, and Linux. Here’s how you can install it on
each platform:

Windows

1. Go to the Shotcut download page.
2. Choose the appropriate installer for your system (e.g., Windows 10/11 on

Intel/AMD or ARM CPU)
3. Download the installer and run it.
4. Follow the on-screen instructions to complete the installation.

Alternatively, you can purchase it for a small price in the Microsoft Store. It is single
lifetime purchase, and doing so helps fund the development. In return, you get
automated updates without needing to re-download and install.

macOS

1. Go to the Shotcut download page.
2. Select the macOS version compatible with your system (e.g., macOS 12+ or

older versions).
3. Download the app bundle and open it.
4. Drag the Shotcut app to your Applications folder.

Linux

1. Go to the Shotcut download page.
2. Download the Linux portable tar or AppImage file.
3. For the portable tar, extract the archive and run the shotcut  shell script.
4. For the AppImage, make it executable and run it directly.

Alternatively, you can install the Flatpak (via Flathub), the Snap, or a package from
your Linux distribution. Often, the software manager in your desktop environment
makes some of these options available to you.

Please be aware that the portable, AppImage, and Snap are all the same build
based on the glibc version in Ubuntu 20.04 and thus stuck to using an older version
of Qt. The Flatpak or distribution package works better on the Wayland graphics
subsystem. Also, the Flatpak or distribution package supports ARM processors
whereas the portable, AppImage, and Snap do not.

Installing Shotcut
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Windows
The installer puts the app icon in the Start menu only (not on the desktop). Use the
Start menu or search for it. When using the portable version, you must extract the
zip file. You should not open the zip file as a virtual folder in Explorer and run it from
there. In Explorer, navigate to where you extracted the Shotcut portable zip file,
locate shotcut.exe  and double-click it. If you want to create a shortcut on your
desktop, right click shotcut.exe  and choose Send to > Desktop from the context
menu.

macOS
It depends on where you drag the app out of the downloaded DMG file, but usually
it is Applications in Finder. If you did add it to Applications, then you can also find
it in Launchpad and search it in Spotlight. After it starts, right-click the app icon in
the Dock, and choose Keep in Dock if you want to launch it from there in the
future.

If you want to run it from the command line run open -a shotcut  or manually run the
executable at /Applications/Shotcut.app/Contents/MacOS/shotcut  per the app nimble
standard. To run a version not installed to Applications  at the command line, use
open /path/to/Shotcut.app . To run another instance of Shotcut at the same time, use
open -na shotcut  or open -n /path/to/Shotcut.app .

Linux
It depends very much on which app package you used, the desktop environment
you use, and sometimes the distribution.

If you are using the portable tar version, first extract the tar file. Then, in your file
manager, double-click the icon in Shotcut. That does not always work. In some
desktop environments, it will only work on the Desktop. In others, it does not work
at all. In GNOME and extracted to the Desktop, you might need to right-click the
app icon and choose Allow Launching. If the file manager does not launch
Shotcut, open the Shotcut.app  folder, and try double-clicking the shotcut  shell
script. Do not try to run bin/shotcut  directly.

If you are using the AppImage, simply make it executable. Then, double-click the
file to run it.

If you are using the Snap, it depends on your distribution. On Ubuntu, after
installing, Shotcut will be in your menu or list of programs and in your $PATH  to
simply run shotcut  at the command line.

Launching Shotcut
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If you are using the Flatpak, after installing, it should be in your menu or list of
programs. At the command line run flatpak run org.shotcut.Shotcut . The upper
case S  is important.



Quick Start Guide on how to use
Shotcut
New Project

Option Description

Projects
Folder

This is where Shotcut will look for your file for editing by default, and
where it will save videos when you export them.

Project
Name

This creates a sub-folder within the named Projects folder, and creates
the project save file when you hit start.

Video
Mode

Important to set this before beginning your project. Leaving this in
Automatic may not produce the results you desire. Example: If you want
to Export a HD 1080p 30 FPS video, set it here first.

Project File Saves

Function Description
Shortcut
Win/Linux

Shortcut
macOS

Save
Saves to a project MLT file. If already saved
previously, updates opened MLT project file.

Ctrl + S
command +

S

Save As

Allows you to choose a new file name
(and/or location) for your current project.
Open project will take on the new file name
and/or file location.

Ctrl +

Shift +
S

shift +

command +
S

Backup &
Save

Performs Save with the ability to make a
backup copy of named.mlt to named yyyy-mm-
ddThh-mm-ss.mlt while keeping named.mlt
active. Must perform function twice to get
date/time saved file.

Ctrl +
Alt + S

option +
command +

S

Editing
There are three modes of editing available within Shotcut.

Modes Description

Timeline
The most popular. Has multiple Video/Audio tracks (or one). Needed for
transitions and voiceovers. No need for the Playlist.

Playlist
Arrange clips in order, apply filters if needed, and then export. No need for
the Timeline.

Quick Start Guide
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Modes Description

Source
Just a single file. Trim if needed and/or apply filters as needed, then
export. No need to use the Playlist or Timeline.

Exporting

Options Description

Presets
Choose a preset that best suits your export needs. If you are a
beginner Stock → Default is your best choice.

From
You can export from Timeline, Playlist, Source, or Marker. If you have
no clips in the playlist or the timeline, or no markers set, these options
will not appear.

Hardware
Encoder

Graphics card encoder may aid with exporting (Read FAQ). Click
Configure, then Detect to set. If nothing is detected then your graphics
card is not compatible.

Export File
Prompts you to name your video export file. Once named, click Save
and export will start. Do not close Shotcut until the export finishes.

Reset Resets all options back to Default.

Advanced

This is where you will find all of the advanced options such as Parallel
Processing, Codec, Rate control, CRF, Bitrate, etc. Warning: The
Advanced moded does not prevent creating an invalid combination of
options!

If you’re a beginner at video editing follow these steps:
To export with the Default settings (frame rate will match your Video Mode)

1. Click on the Export icon at the top, right.
2. Export File
3. Name your video file.
4. Wait for Shotcut to finish exporting.

After the export is done, you can double clock on the job to play your finished video
within Shotcut.

The longer the video project, amount of filters, and computer specifications will all
be factors in how fast your video export takes to complete.

Troubleshooting
At times exporting may fail. Video filters may not perform the way you expect them
to. Or some other issue that you may not understand. Video editing is a very
complicated task for anyone and their computer. Do not be afraid to ask for help.

First start by reading the FAQ (Frequently Answered Questions). Several issues
are addressed in there.

https://www.shotcut.org/FAQ/#how-does-shotcut-use-the-gpu-or-not
https://shotcut.org/FAQ/


Search the forum for the issue you’re having. If you can’t find the answer, feel
free to make an account and post your issue. The forum is made up of many
volunteers who also use Shotcut.

Look through the Tutorials section of the forum.

Watch Tutorial Videos specifically chosen by the developers.

https://forum.shotcut.org/c/tutorial/5
https://shotcut.org/tutorials/


Introduction
Shotcut does not provide very much in the way of project management at this time.
Rather, you are required to manage many aspects of this. There are a few things
you should know:

Shotcut saves to a project file in a text format called MLT XML. (Technical detail
on that format can be found here.)
The project file does not contain any of your media. Rather, it only links to your
media files by file system path and name.
There are 3 different kinds of projects:

1. Clip
If you put anything in Playlist or Timeline and you open a media file (or
generator), then you can save it as a clip-only project along with trimming
information as well as filters and their keyframes.

2. Playlist
If you add some things to the Playlist but not the Timeline, then you have
saved a playlist-only project.

3. Timeline
This is what most people use, but keep in mind it is not necessary to use the
timeline. Any of the above can be exported as a final audio/video file!

Project Folder
Shotcut supports the concept of a project folder, which is optional. A project folder
is when you create a file system folder for your project and you put project file in
there along with whatever companion files get created as well as media files if you
choose.

When Shotcut first starts (or after you choose File > New or File > Close), this
view appears in the area for the Source player:

Project Management
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You use this to create a project folder. When you use it, Shotcut creates a folder on
the file system with the name in Project name within Projects folder. Then, it
saves an empty project with the name in Project name followed by .mlt .
Thereafter, companion files that Shotcut creates are saved automatically into the
project folder instead of requiring you to name them:

Stabilize video filter
Text: HTML video filter
Properties > Reverse
Text to Speech
Record Audio
Screen Snapshot
Screen Recording (depending on operating system, see Screen Recording
Generator)
Image/Video from HTML
New > Animation
Mask: Draw video filter
Settings > Proxy > Storage > Use Project Folder

We encourage you to store all or most of the media files that you use in the project
in the project folder. However, Shotcut does not provide a way to automatically
copy or move the files into there automatically at this time. Use your operating
system’s file manager for that. If you move the files after they were added to the
project, the next time you open the project it will show a missing files dialog where
you can re-link them to the project folder.

You can also store multiple .mlt  (MLT XML) files in your project folder. You could
be nestinge/embedding child MLT XML files within the parent project file, or you
could use this to have multiple timelines in a project (each timeline is its own MLT
XML file). If you have Settings Backup turned on, the backup files are saved in this
project file too.

Use the Files panel (menu item View > Files) folder path drop-down and

choose Current Project to view its contents. Or use from the menu File > Show
Project in Folder to open your operating system’s file manager to the project
folder.

Of course, you can skip using this because it is entirely optional, and the view goes
away as soon as you open something. Also, you can create a project folder
manually by not using this, but Shotcut then does not provide the automatic naming
and placement of the companion files.

Relative vs. Absolute File Names
Shotcut saves MLT XML with file paths and names rather than embed any media.
So, it can save these paths in full (i.e. absolute) or partially (i.e. relative). On
Windows, a full path begins with a drive letter such as c: . On Linux and macOS, a
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full path begins with a slash ( / ). Shotcut saves with a relative path if the file is in
the same folder as the .mlt  project file or a sub-folder of this folder. It saves with
an absolute path otherwise. This means your project file can be a mix of the two; it
is determined per file.

There are different schools of thought around which to use. If you use absolute
paths, you can keep media where you have it already organized and freely move
the project document without any impact. If you use relative paths, you can put
everything into a single folder (optionally with sub-folders), and freely move around
the project folder. Take your pick; Shotcut does not force you into either one.

Example : Relative File Structure
D:/Shotcut/ZProject (File Folder)
D:/Shotcut/ZProject/Zproject.mlt (Current project MLT file)
D:/Shotcut/ZProject/BugV.png (Source Location)
D:/Shotcut/ZProject/Square/BugS.png (Source Location)

When saved, the MLT file has the Source file locations as such:

BugV.png
Square/BugS.png

You can copy the file folder D:/Shotcut/Zproject which is helpful for sharing with
people or to another computer. Also useful for backing up saved projects for later
use.

Example: Absolute File Structure
D:/Shotcut/XProject (File Folder)
D:/Shotcut/XProject/Xproject.mlt (Current project MLT file)
D:/Shotcut/ZProject/BugV.png (Source location)
D:/Shotcut/ZProject/Square/BugS.png (Source location)

When saved, the MLT file has the Source file locations as such:

D:/Shotcut/ZProject/Bug Vertical.png
D:/Shotcut/ZProject/Square/Bug Square.png

The folder of D:/Shotcut would need to be copied for sharing with people or to
another computer. If you tried to share XProject.mlt along with your source files
individually to another person they would be presented with this dialog box.

Autosave
Autosave is always working and cannot be turned on or off. It does not save to your
existing project. Rather, it saves to a hidden file in your app data directory. Then, it
is checked when you reopen a project. It is only meant for crash recovery. Every 60



seconds it checks if the project is modified (the window title bar shows an asterisk
except on macOS which uses the red dot) and saves to the backup file. When you
reopen a project after a crash, if the backup is found, Shotcut prompts you to use it:

Once you save successfully - including save at exit when prompted, - the backup
file is removed. This also works for projects that were never saved - an Untitled
project. Except in that case, simply restarting Shotcut will attempt to locate a
backup and prompt. Otherwise, for a named project, you need to open the project
for it to check.

Missing Files
Shotcut presents a missing dialog box when you open the project if a file has been
moved or deleted or file folder has changed name. This allows you to still use your
existing project, but you must tell Shotcut where to find your source file.

Double click each item that’s missing as assign the source files a new location.

One files have been found, then click OK.

You will now have two project files. The original, and a Repaired project MLT file.
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There are many ways to import media files in Shotcut.

Open File
From the main toolbar or from the File menu, click on Open File.
Or use the keyboard shortcut Ctrl+O (comman+O on macOS).

         

         

Navigate to the folder containing the media file (or files) you want to import.

Select your file(s) and click on the Open button.

If only one file is opened, it will automatically be added to the Source panel. From
there it can be dragged to the Playlist, or to the Timeline.

If multiple files are opened, they will all be added to the Playlist. The first file in the
list will open in the Source panel.

NOTE: Open File cannot be used to import a MLT XML file as clip.

From the Playlist
The Playlist panel can be used to import files in a project, including MLT XML file
as clip.

At the bottom of the Playlist panel, click on the Add files to playlist button.

Navigate to the folder containing the file (or files) you want to import.

Select your file(s) and click on the Open button.

Adding Media
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The file(s) will be added to the Playlist. From there, any or all of them can be
moved to the Timeline when needed.

Drag from a folder
You can add files (including MLT XML file as clip) to your project by dragging them
from a folder

Open the folder containing the file(s) you want to import.
Select the file(s).
Grab and drag the file(s) in the Playlist or in the Timeline..
You can also grab and drag the file(s) in the Source panel.
If you drag multiple files at once in the Source panel, they will all be added to
the Playlist, and the first file in the list will open in the Source panel.

https://forum.shotcut.org/t/open-mlt-xml-as-clip/12946


In video editing, trimming is the process of adjusting the start (in-point) or end
(out-point) of a video or audio clip to shorten or lengthen its duration. This is
different from moving the clip on the timeline; it’s about changing the content and
duration of the clip itself.

While some software uses a dedicated trim tool, in Shotcut you perform trimming
directly within the Timeline or Source player using controls and keyboard
shortcuts.

A good workflow involves using the Source player to prepare clips before adding
them to the timeline. This helps you select and trim the best parts of your footage
first, which saves time and makes the editing process on the timeline more efficient
and less disruptive.

Source Player
You can open a clip into the Source player a number of ways:

File > Open (menu, main toolbar, shortcut)
drag from a file manager & drop onto the player
double-click in:
Recent
Playlist
Files

Drag  to change the in-point.
Drag  to change the out-point.

Trimming Clips
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Alternatively, play and seek within the clip to position the playhead: 
Then, press I  to set the in point and/or O  (letter O , not the number 0 ) to set
the out point.

As you are trimming the bottom, right corner of the player shows some time
values. Remember, there are tool tips through the application. Hold the mouse a
couple of seconds over one of the time values to reveal its purpose: In Point /
Selected Duration. Note that, technically, duration is not the out point. If you
actually move the playhead to the out-point, the time field in the bottom, left corner
shows the out point. However, more often the duration of this sub-clip is more
interesting than the out point.

Sub-Clip and Playlist
A sub-clip is a new, shorter clip created from the larger, original media file. Instead
of keeping the entire clip, you create a sub-clip that contains only the specific,
trimmed segment you want to use. This is a common practice in the Source player,
where you set the in-point and out-point of a desired section and then add it to the
Playlist. Sub-clips are useful for organization, as they allow you to work with
manageable, focused pieces of a long recording without affecting the original
footage. You can have multiple sub-clips from the same source in the playlist or
timeline. You can also add Filters to the sub-clips while preparing it in the Source
player.

Timeline
Clips on the timeline also have interactive controls for trimming. Move the mouse
cursor to the left edge of a clip, and you see a green bar appear:

Drag it to trim the in point.
Move the mouse cursor to the right edge of a clip, and a red bar appears:

Drag it to trim the out point.
You can also use the I  and O  keys to on the timeline.

Regardless of the approach, in the timeline the behavior also depends on
something called Ripple, which is a fundamental concept in video editing and
especially in Shotcut. For the interactive mouse control, ripple is used when this
timeline toolbar button is active:

When the button is not active, you can hold Shift  while trimming to do a ripple
trim.

https://forum.shotcut.org/t/glossary-terminology/12413#p-39168-ripple-21


There are ripple variants of the keyboard shortcuts:

Shift + I  for Ripple Trim Clip In
Shift + O  for Ripple Trim Clip Out

Another thing to note about using the timeline keyboard shortcuts is that you do not
need to first select the clip. It operates on the topmost clip under the playhead. But
an important consideration is that shortcuts on the timeline cannot increase the
duration. It can only decrease by removing more from the beginning or end.

Roll Edit
A roll edit is a specific type of trim that adjusts the cut point between two adjacent
clips on the timeline simultaneously. The defining feature of a roll edit is that it
shortens the end of the first clip and lengthens the beginning of the second clip by
the exact same amount. This means the total duration of the two clips—and your
entire video sequence—remains unchanged.

You use a roll edit to refine the timing and rhythm of a transition without affecting
the rest of your timeline. It allows you to shift the “moment of the cut” to a more
effective point, such as aligning a visual cut with a beat in music or a specific word
in dialogue.

In Shotcut, hold Ctrl  when trimming to perform a roll edit.

Scrub While Dragging
“Scrubbing” is essentially another word for seeking, but it is a bit more about
playback than simply going to a point in time. Think of it as rapidly seeking short
distances while updating the video preview. This can be useful when trimming or
doing a roll edit. In Shotcut, this is on when the timeline toolbar button is active:

Otherwise, when it is off, you can still kind of see where you are inside the clip by
viewing the thumbnail on the timeline.



Three-point editing is a technique used in video editing to manipulate footage by
using three reference points: an in-point, an out-point, and a cut point. It’s
particularly useful when you need to extract a segment from a source clip and
insert it in your Timeline. The segment can also be inserted into to the Playlist.

The Three Points
In Point

This is the starting time of the segment you want to insert into the Timeline. In the
Source player, you set the in-point at the specific frame where you want the clip to
begin.

The keyboard shortcut used to set the in-point is I .

Out Point

This is the ending time of the segment you want to insert. In the Source player, you
set the out-point at the specific frame where you want the clip to end.

The keyboard shortcut used to set the out-point is O  (the letter O , not the
number 0 ).

Cut Point

This is the location in the Timeline where you want to insert or overwrite the new
clip. To set the cut point, move the playhead at the frame where you want the new
clip to be inserted. If there is more than one track in the Timeline, also make sure
to change the current track to where the segment needs to go.

Edit
The last step is to execute the edit operation: Paste (insert) or Overwrite. Drag-n-
drop is not recommended but still possible. With drag-n-drop the playhead is only a
visual cue and not as precise.

Three Point Editing
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The Undo and Redo functions in Shotcut are crucial for managing your editing
workflow efficiently.

Undo:  The Undo feature allows you to revert the last action you performed.
Whether you added a clip, adjusted the filters, or made a cut, you can easily
reverse the change by clicking the Undo button (or using the keyboard shortcut
Ctrl + Z ). This can be repeatedly used to step back through multiple

actions.

Redo:  The Redo function is the counterpart to Undo. If you have undone an
action and decide you want to keep it, the Redo button (or the keyboard shortcut
Ctrl+ Y  on Windows or Ctrl + Shift + Z  on Linux and macOS) will
reapply the most recently undone action. Like Undo, you can use it repeatedly to
step forward through your action history.

History Panel: Shotcut also features a History Panel, which provides a visual
timeline of your editing actions. This panel allows you to see and navigate
through your actions quickly, making it easier to manage complex edits. Access
the History Panel by going to View > History.

There is a default maximum of 50 items for the history, but it can be increased
using the configuration key undoLimit .

Undo and Redo
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Trimming a filter means you can choose when the filter effect starts and ends
independent of the clip’s starting and ending time. Obviously, if the filter is applied
to a clip, it must still be within the clip’s time frame. If the filter is applied to a track,
however, it can be truly independent. Filter trimming takes place in the Keyframes
panel:

The first row of the Keyframes panel shows the clip with its thumbnails and audio
waveform. Drag the left, green edge to change when the filter starts. Drag the right,
red edge to change when it ends. Here is how it looks when both ends of the filter
have been trimmed:

The dimmed portion of the clip reflects when the filter is inactive.

With version 19.10.20, toolbar buttons and keyboard shortcuts for filter trimming
were added.

These are the toolbar buttons:

Trimming Filters
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These are the keyboard shortcuts:
[  to set the filter start

]  to set the filter end

Using these buttons and keyboard shortcuts will speed up the process of precise
filter trimming considerably. Simply place the playhead at the desired point and
press the filter start or end button/keyboard shortcut.



The timeline is the least accessible part of the Shotcut UI. You do not need to use
the timeline in Shotcut. It is possible to make single-clip-only and playlist-only
projects in Shotcut. I think we should start there. In a clip-only project, you can
open a single clip, trim and filter it, and then export it. For this, you only need
Ctrl+O to open a file into the Source player. Then, you can refer to all of the
keyboard shortcuts under the player section. When you use left and right arrow
keys here you should hear little audio blips as long as “Scrub Audio” is turned on in
the Settings menu. If you still do not hear the audio, then this feature is
incompatible with the format or encoding of some files. In the Properties panel
there is a way to convert a file into what I call an edit-friendly format to fix that.
Next, Press I to set the start frame, and press O to set the ending frame. Finally,
you can export the sub-clip.

Now, you can also do the above repeatedly; but, instead of export, add each sub-
clip to the playlist. When done, you can export the playlist, which will concatenate
all of the sub-clips.

Initially, the playlist panel is not open, and that is OK. With a clip opened and
trimmed, you can press shift+a to add it. That opens the playlist panel for you, but
maybe you do not need to do anything else at this time except to export it of
course. You can add more to the playlist by repeating everything you have done
thus far. You can play the entire playlist by pressing the escape key and use the
same playback shortcuts. Press escape key again to return the clip player, which
has the label “Source”. Exporting the playlist is simple. As soon as you add
something to the playlist, export automatically defaults to export from the playlist.
This can be confirmed using the drop-down control labelled “From” in the export
panel.

Let me give you a tip about the toggles for the different panels. When you use the
View menu or keyboard shortcuts, it will toggle the visibility of the panel. However,
the main toolbar buttons always make it visible - not a toggle - and raises the panel
in case it is tabbed behind another panel. I just noticed that neither of these
methods give focus to the panel. Panel focus is difficult in this UI and for most
users. So, Shotcut demphasizes it. However, sometimes it is needed. I guess your
voiceover software lets you search the UI and take focus. Each panel does have
like a sub-window title, and maybe you can find it that way. This panel title is also
reflected in the tab in case the panel is tabbed with another panel.

A Guide for Blind Users
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Here are ways to reduce the memory usage in general:

Save and restart Shotcut
Close other browser tabs.
Close other applications.
Reboot (does all of the above).

Here are ways to reduce the memory usage of your project:

Reduce the resolution of the Video Mode.
Reduce the number of tracks. The number of tracks will increase the amount of
caching to prevent files from being closed and reopened repeatedly from one
frame to the next.

Here are some ways to reduce the memory usage while editing:

Make sure Settings > Realtime is turned ON. When it is off, it uses more
threads, and more threads needs more memory.
Use Preview Scaling and Proxy Editing.

Here are some ways to reduce the memory usage while exporting:

See all of the things list above about reducing memory usage in general and of
the project.
Turn OFF Export > Advanced > Video > Parallel processing. That uses more
threads, which needs more memory.
Turn ON Export > Use hardware encoder (use Configure… > Detect if
needed).
It can be very helpful to reboot, start Shotcut and only Shotcut after reboot, open
the project but do not play through it, and then export. You are then guaranteed
to give the most of your available physical memory to the Shotcut export
process.

How to Reduce Memory Usage
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Introduction
Some users report that their clip looks “washed out” or “pale” in Shotcut compared
to media players. This is often because the clip is encoded as High Dynamic Range
(HDR). Shotcut has very limited support for editing HDR, and most users do not
want to bother with HDR output. So, HDR clips can be converted to SDR that
Shotcut can edit.

Identifying HDR Clips
To identify HDR clips in Shotcut, open the clip and view the Properties panel. In the
properties panel, look for the “Color transfer” field in the Video tab.

The following Color transfer types are HDR:

SMPTE ST2084 (PQ)
SMPTE ST428
ARIB B67 (HLG)

Transcode HDR to SDR
When opening HDR clips in Shotcut, you may be prompted to convert the file. If
you are not prompted, follow these steps:

Editing HDR Source Clips
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1. Click Convert… in the Properties panel. A dialog window opens.
2. Open the “Advanced” section of the dialog.
3. Ensure that the Convert to BT.709 colorspace checkbox is checked.
4. Click OK to start the conversion.

After the conversion is complete, the clip will be replaced with the converted clip.

Convert Color With a LUT
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Instead of converting a HLG HDR clip, you can use it as-is with or without a proxy
and use a LUT to convert it to SDR. Our Resources page has a LUTs section with
some freely downloadable LUTs from NBC/Universal that can convert from HLG
HDR to BT.709 SDR. “SL” in the file name means scene light, and “DL” means
display light. Use either of these with the LUT (3D) video filter.

Convert Using Another Tool
There a different ways to convert HDR to SDR since the result is only an
approximation of the source. Shotcut’s Convert gives a result some people do not
like. A lot of people mention using the popular Free, open source, cross-platform
Handbrake video transcoder.

If you are using macOS and shooting HDR video with an iPhone you can use
QuickTime Player:

1. Choose File > Export As
2. Pick a resolution and a file dialog opens
3. At the bottom of the dialog is a drop-down where you can choose:

Greater Compatibility (H.264)

How to Edit HLG HDR Video With
Shotcut
Version 25.05 of Shotcut added limited support for editing, processing, and
exporting HDR video. This is focused on HLG HDR at this time because my
cameras are iPhone and GoPro HERO13 that both can shoot in HLG. It is also
possible to record in log color, but that is not the focus here.

Limitations
No embedded HDR preview! You can only see the HDR video as HDR in
Shotcut when using a Blackmagic Design SDI/HDMI device with Settings >
Player > External Monitor. As an upside for this, since HLG is supposed to
provide a satisfactory experience when viewed on a SDR screen, this gives you
a way to simultaneously preview both SDR and HDR.
If you want to do any filtering, transitions, or track blending/compositing you
must enable Settings > Processing Mode > Linear 10-bit GPU/CPU and limit
yourself to video filters with the tags #gpu  or #10bit  on 10-bit video sources.
(GPU filters always support a 10-bit workflow but not all CPU video filters.)
When not using GPU processing, you can do a simple cuts-only editing
(trimming and sequencing). It is OK to include text on a solid color or still image
with this, but its color will look a little different than the preview.
There is a bug in version 25.05 converting color range of 10-bit video between
full and limited. You should export the same range as the source. This has been

https://shotcut.org/resources/#luts


fixed for the next version.

A Simple, Inexpensive Setup for HLG HDR
This also includes how I do 5.1 surround sound.

recording with GoPro MAX and HERO13 cameras – less than $500 each,
previewing on a 42" 4K HDR (800 nits) Samsung TV I bought in 2018 for about
$650,
using a Blackmagic Design DeckLink Mini Monitor 4K that I bought this year
for $200, and
playing through a Sony AV receiver I bought in 2018 for less than $200.

Shotcut Settings
Turn on Settings > GPU Effects.
Choose Settings > Audio Channels > 6 (5.1 surround) if desired.
Create and use a custom Video Mode with Colorspace = ITU-R BT.2020.
Ignore conversion dialogs when importing video.
Add and edit media as usual. For video filters on HLG video sources, use only
#gpu  and #10bit  filters. You can use these tags when searching filters.
To convert first order (4 channel) Ambisonic audio to 5.1 surround, use the
Ambisonic Decoder audio filter.
It improves performance to use proxies and preview scaling, but the proxy for
HLG must have been created with version 25.05 or later.
In Export, select a preset from the “ten_bit” category. I have tested AV1, HEVC,
and ProRes.
If the Shotcut version is 25.05 and the source HLG video is primarily full color
range (for example, GoPro HERO13 is but not iPhone), set Export > Video >
Color range = Full (JPEG).
In Export > Other add the line color_trc=arib-std-b67 .

https://www.blackmagicdesign.com/products/decklink


Introduction
Sometimes users report that Shotcut is not frame accurate. For example, they split
a clip on a certain frame, but then later the split is not where they expected it. Or,
they put a keyframe on a certain frame, but later the keyframe seems to be on a
different frame. Also, sometimes people report that the audio and video out not in
sync.

Symptoms like these can be caused by Variable Frame Rate (VFR) source clips.
Some users report that VFR clips work in Shotcut if the VFR is subtle. Other clips,
however, are completely unusable in Shotcut.

Identifying VFR Clips
Some programs will skip encoding frames as a way to reduce file size. Also, some
devices will skip encoding frames if they do not have enough processing power to
perform real time encoding. Typically, these clips can be identified by looking at the
frame rate in the properties panel. If the clip frame rate does not match a standard
frame rate, then it is probably VFR. If Shotcut is able to detect a VFR clip, it will add
a “(variable)” tag after the frame rate. But Shotcut can not always detect VFR clips.

Converting VFR Clips

Editing Variable Frame Rate Source Clips
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The best way to edit VFR clips is to convert them to a fixed frame rate. Follow
these steps:

1. Set the desired Settings > Video Mode in Shotcut (do not use Automatic). In
particular, choose a frame rate for your project that meets your needs.

2. Open the VFR clip
3. If Shotcut detects the VFR, it may prompt you to convert. If not, click the

“Convert…” button in the properties panel to open the conversion prompt.
4. Click “OK” to start the conversion

After the conversion is complete, the clip will be replaced with the converted clip.

https://forum.shotcut.org/t/video-mode/12790


The New Project view is the primary screen shown when Shotcut is launched. It
serves as an optional starting point for work, ensuring that your project is organized
and that the technical foundation (resolution and frame rate) is correctly established
before media is added.

To start a new project, you must complete the three primary fields in the center of
the application window. If you are already working in a project, you can return to
this screen via File > New or Ctrl+N  ( Cmd+N  on macOS).

1. Projects Folder

This is the parent directory on your computer where Shotcut will save your project
folders.

How to set: Click the text or the folder icon to browse your system.
Best Practice: Choose a dedicated folder for video editing so all your projects
are kept in one location.

2. Project Name

Enter a descriptive name for your current work (e.g., “Summer_Vacation_2024”).

Behavior: When you click Start, Shotcut creates a sub-folder with this name
inside your Projects folder and creates an empty .mlt  project file within it.
Storage: You can optionally to store all the media (video, audio, and images)
you plan to use inside this specific project folder to avoid “missing file” errors
later.
Generated files: Shotcut can generate files for certain tasks such as
Stabilization or generating an image from HTML. When using this feature to
make a project folder, Shotcut automatically saves them to this folder instead of
asking you every time where to put it! This only works if you press the Start
button, simply entering a name here does nothing in and of itself.

3. Video Mode

New Project
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The Video Mode is the most critical setting. it defines the resolution (e.g., 1080p),
the aspect ratio (e.g., 16:9), and the frame rate (e.g., 30 fps) of your project.

Automatic (Default): Shotcut will leave the settings blank and automatically set
the Video Mode based on the properties of the first file you drag onto the
Timeline or Playlist. Not the first file at any later point in time as you make
changes. Literally, the first time you add something, the video mode is set and
locked in until you change it with Settings > Video Mode.
Manual Selection: You can click the drop-down to choose from various presets
(HD, 4K, Vertical/Social Media).
Important: It is best to set this manually if you know your final delivery
requirements. Changing the Video Mode mid-project can occasionally cause
filters or transitions to misalign.
This does not change Settings > Video Mode if you start a project without
clicking the Start button!!

Starting the Project
Once these fields are filled, click the Start button.

The Timeline, Playlist, and Player will be initialized according to your Video
Mode.
The window title bar will now display your project name followed by an asterisk
(*) if there are unsaved changes.

Recent Projects List
On the right side of the New Project view, Shotcut maintains a list of recent
Projects.

Quick Access: Simply click a project name in this list to immediately reload that
work.
Search: Use the search bar at the top of the Recent panel to find older projects
by name.
Removal: To remove a project from the list, right-click it and choose Remove.
Removal only removes the project from this list; it does not remove any files.
Use your operating system’s or preferred file manager, such as Explorer on
Windows or Finder on macOS, to manage files.

See also Project Management, Settings > Video Mode, View > Recent

https://forum.shotcut.org/t/project-management/12574/1
https://forum.shotcut.org/t/video-mode/12790/1
https://forum.shotcut.org/t/recent-panel/12941/1


See Keyboard Shortcuts page on the main web site.
As of version 22.09 you can edit or add your own using Help > Actions and
Shortcuts.

Keyboard Shortcuts

https://shotcut.org/howtos/keyboard-shortcuts/
https://forum.shotcut.org/t/actions-and-shortcuts-window/35892
https://forum.shotcut.org/


Both of these commands do the same thing

1. If you have un-saved work you are first asked if you want to save your project.
2. If a file is open–whether a project, saved or unsaved, or a single piece of media–

the current project is closed and all clips and timeline tracks are removed from
the window. It will look similar to how it appears when you start the program by
itself (not by launching it along with a project or media file).

3. Close does not close the Shotcut program; use Exit for that.
4. If you already did some things in Shotcut you need to choose Close or New in

order to return to the New Project view.

See also Project Management

File > New > Project and File > Close

https://forum.shotcut.org/t/project-management/12574
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These actions save your project to a file format that is specific to Shotcut so you
can resume editing at a later time. If you want to output a video (or audio only) file
that plays in any other media player or to share use Export.

Save

Saves current project to a .mlt  file you name.
Repeat using Save continues to save current project to the same specified file.
Shortcut Ctrl + S  (macOS Cmd + S )

Save As

Saves current project to a .mlt  file you name (possibly different).
Repeat using Save As will offer you a new file name to save as each time.
The last Save As file you name will be the current project file open in Shotcut.
Now when using Save it only saves to this current project file name.
Shortcut Ctrl + Shift + S  (macOS Shift + Cmd + S )

Backup and Save
This is only available if you have already saved a project (“Untitled” does not
appear in the window title bar). It first gets the last date and time the project file was
modified. Then, it duplicates the current project file with a new name that ends with
the date and time of last modification. Finally, it saves the changes.

This menu item was added in version 23.09.

File > Save and Save As

https://forum.shotcut.org/t/export-basics/12953
https://forum.shotcut.org/uploads/default/original/2X/6/6f9ddd8c9e49057388fbbfb4d21e88fa307bb9a1.png
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Making backup copies of a project can be very helpful in case we want to go back
to a known good state of the project.

A project backup can be created, either manually with File > Backup and Save or
automatically with Settings > Backup.

When a backup occurs, the project backup appears in File > Other Versions.

File > Backup and Save
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In Shotcut, the “Open MLT XML as Clip” feature allows you to import an MLT XML
file directly into your project as a single clip. This means that instead of treating the
XML file as a project file with multiple elements like video clips, audio tracks, and
effects, Shotcut treats it as a single media item that can be placed on the timeline
like any other clip.

Using this feature can be handy if you want to incorporate a pre-edited project into
your current project without having to import each individual element separately. It
simplifies the process by treating the entire XML file as a single entity, making it
easier to manage and manipulate within your project.

Like any other type of clip, a MLT clip can be trimmed and have filters applied to it.

MLT clips work best when the profile of the clip matches the profile of the project it
is being added to. To make this easier, the properties panel for an MLT clip will
display the profile properties and a validation if the clip matches the project profile:

MLT clips with a profile that does not match the project profile can still be used. But
it may result in lower quality or performance.

To import a “MLT XML” file as a clip you can either:
1. Use the “File” menu

Open the File menu and click on “Open MLT XML as clip…”

Navigate to the folder containing the MLT file you want to import.
Select and open the file.
The MLT file will open in the the Source panel, and from there it can be moved
to the Playlist, or to the Timeline.

2. Use the Playlist panel

File > Open MLT XML as Clip
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Open the Playlist panel.
Click on the “Add files to playlist” button

Navigate to the folder containing the MLT file you want to import.
Select and open the file.
The MLT file will be added to the Playlist, and from there you can move it to the
Timeline.

3. Drag it from a folder

On your computer, open the folder containing the MLT file you want to import.
Select the file and drag it in Shotcut, either to the Source panel, the Playlist, or
the Timeline.

https://forum.shotcut.org/t/about-the-playlist/12951


Export Frame is a feature that lets you save the frame currently displayed in the
Shotcut viewer as a still image. The available formats are: PNG, BMP, JPEG, PPM,
TIFF, or WebP.

Export Frame was added in Shotcut version 16.07

After moving the playhead to the desired frame, you can export the image by
either:

Using the Ctrl + Shift + E  keyboard shortcut.
Going to File > Export and choosing Frame…

In the export dialog box, Shotcut automatically generates a file name
corresponding to the position of the playhead, but you can use a custom name if
you prefer. This is also where you can choose the file format.

This saves the frame as it is displayed in the viewer, including any changes made
with filters or from options in the Settings menu (e.g., Proxy).

Upon saving, the new file is added to the Recent panel for easy access in Shotcut.

This feature makes it easy to achieve a freeze frame effect:

File > Export > Frame

https://d2t917e3b1b2xy.cloudfront.net/original/3X/d/6/d6c6c47d16bae453283b6012a9d2472e05a0fff0.png
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Move the Playhead to the desired frame on the timeline.
Export the frame.
In the Recent panel, double-click on it to copy it in the Source viewer.
In the Timeline toolbar, click on the Paste button to insert the still image at the
position of the Playhead.

It’s also convenient for creating a custom thumbnail for your web video:

Export the frame you want to use as a thumbnail.
In the Recent panel, double-click it to open it in the Source viewer.
Apply a Text filter to add a title.
Use Export > Frame again to export the new thumbnail.



Exports the current timeline as an EDL (Edit Decision List) file.
An EDL is a text-based interchange format that describes editing decisions, not
media content.

What an EDL is
An EDL records how a timeline is edited, including:

Clip order
Source in/out points
Timeline in/out points
Basic transitions (usually cuts only)
Track assignments (limited)

It does not contain video, audio, effects, or rendered output.

An EDL answers the question:

“How the edit is put together?”
not
“What does the final video look or sound like?”

Purpose of exporting an EDL
EDL export is primarily intended for interoperability and offline workflows, such as:

Moving an edit from Shotcut to another NLE
Conforming an offline edit to higher-quality media
Archiving edit decisions separately from media
Educational or documentary workflows

It is not meant for final delivery.

What is included in Shotcut’s EDL export
Typically included:

Clip references
Source timecodes (in/out)
Timeline placement
Simple cuts

Typically not included:

Filters or effects

File > Export > EDL
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Transitions beyond simple cuts
Speed changes
Keyframes
Color correction
Audio filters
Generators
Titles
Compositing or track blending
Most multi-track relationships

EDL support is intentionally minimal.

Format characteristics and limitations
Plain text format
Line-based, rigid structure
Originally designed for linear tape editing
Limited metadata capacity
No extensibility for modern effects

Note:

The EDL format is limited to a single video track and a small number of audio
tracks (commonly up to four).

Because of this, EDLs are lossy representations of modern timelines.

Compatibility with other software
EDL is an old but widely recognized format.

Commonly supported (non-exhaustive list):

Natron
Blender (VSE)
Pitivi
KDEnlive
DaVinci Resolve
Avid Media Composer
Adobe Premiere Pro (import with constraints)
Final Cut Pro (via conversion tools)
Various conforming and finishing systems

Important:
Each application interprets EDLs slightly differently. Results may vary.

Requirements and expectations



To successfully use an exported EDL:

Source media must be available to the target application
File names and timecodes must match
Reel names (if used) must be compatible
Expect manual cleanup after import

EDL workflows assume editor intervention, not one-click transfer.

What this export is not
Not a project backup
Not a render
Not a universal interchange format
Not suitable for complex timelines

Recommended use cases
Rough cut transfer
Offline-to-online conform workflows
Archival documentation of edit decisions
Educational demonstrations of editing structure
Legacy broadcast workflows

Practical usage note

If your timeline relies heavily on filters, effects, compositing, or generators,
exporting to EDL will produce a simplified and incomplete representation of
the edit.

This is expected behavior, not a bug.



Keyboard Shortcut Ctrl + Shift + 3  ( shift + command + 3  on
macOS).

The Notes icon on the top toolbar will open/close the panel.
Menu: View → Notes

Use the new Notes panel to keep notes about your project.
This panel can moved to other panel sections.

View > Notes
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The Filters Panel allows you to add and manage effects and adjustments to your
video and audio clips. You can apply a variety of filters to enhance your media,
such as color correction, size and position adjustments, masks, blurs, audio
adjustments and many more. Most filters come with customizable settings.

This panel also lets you:

Manage the order of applied filters.
Disable/Enable applied filters.
Copy and Paste filters.
Create and save Filter Sets.

Display/Hide the panel

   If the Filters panel is not visible in the interface, you can either:

Click the Filters icon on the main toolbar 
Go to the top menu and select View > Filters
(can also be used to hide the panel)

   If the panel is visible, but all buttons are grayed out, either:

Select a Clip, a Track head, or the Output track in the Timeline.
Copy or Cut any clip from the Timeline and switch to the Source viewer.
Double-click any item in the Playlist to copy it to the Source viewer.
Double-click an image, video or audio file in the Recent panel to copy it to the
Source viewer.

To view a list of all available filters, see the Documentation Table of Content

View > Filters

https://forum.shotcut.org/t/filter-sets/40787
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The History Panel in Shotcut allows you to manage and navigate through your
editing actions efficiently. Here’s how to make the most of it:

Accessing the History Panel: To open the History Panel, click the History icon
 on the main toolbar or go to the top menu and select View > History. This

will display a list of all your recent editing actions in chronological order.
Using the History Panel: The History Panel lists each action you’ve taken in
your current editing session, such as adding clips, applying filters, or making
cuts. By clicking on any item in the list, you can revert to that specific point in
your editing timeline. This can be particularly useful for complex edits where you
need to quickly backtrack and make adjustments.
Undo and Redo Integration: The actions in the History Panel are directly tied to
Shotcut’s Undo and Redo functions. If you undo an action from the History
Panel, it will appear in the panel, allowing you to easily redo it if necessary.
Managing History: The panel not only helps you track changes but also allows
you to delete specific actions from the history if you wish to simplify your action
list.

By incorporating the History Panel into your workflow, you can streamline your
editing process and make adjustments with confidence and precision.

View > History
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The Jobs panel is Shotcut’s background task manager. It displays the status and
progress of intensive processes—such as exporting video, creating proxies, or
converting files—allowing you to continue editing or queue multiple tasks without
waiting for each one to finish individually.

Opening the Jobs Panel
If the Jobs panel is not currently visible, you can display it using these methods:

Toolbar: Click the Jobs icon on the top main toolbar.

Keyboard Shortcut: Press Ctrl + 0  (Windows/Linux) or Cmd + 0  (macOS).
Menu: Go to View > Jobs.

The Jobs Interface
The Jobs panel typically appears on the right side of the interface. It contains a list
of all tasks initiated during the current session.

Job Status Indicators

Pending (Empty Bar): The job is in the queue and will start automatically when
previous jobs finish.
Running (Percentage/Progress Bar): The job is currently processing. You can
see the elapsed time and an estimate of the remaining time.
Finished (Checkmark): The task completed successfully.
Failed (Red X): The task encountered an error. You can right-click these to view
a log for troubleshooting.

Right-Click Menu Options
Right-clicking any job in the list provides several management and diagnostic tools:

Option Description

Stop Cancels a running job.
Remove Removes the entry from the Jobs list (does not delete the actual file).

View Log Opens a text window showing the technical output of the process.
Essential for diagnosing “Failed” exports.

View XML
Displays the MLT XML code that was sent to the background “Melt”
engine to process the job.

Open Opens the resulting file in the Shotcut Source Player (useful for
checking a finished export).

View > Jobs
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Option Description

Show in
Folder Opens your system’s file explorer and highlights the finished file.

Repeat Restarts a finished or failed job using the original settings.

Common Job Types
Export: Triggered when you click “Export File” in the Export panel.
Proxy: Generated automatically if “Use Proxy” is enabled in Settings.
Convert to Edit-Friendly: Created when you choose to optimize a variable
frame rate or highly compressed clip.
Reverse: Created when you use the “Reverse” tool in the Properties panel.

Queue Management
Sequential Processing: By default, Shotcut processes one job at a time to
maximize system resources. As one job finishes, the next in the list begins
automatically.
Pausing: You can right-click in the empty space of the Jobs panel to Pause the
entire queue. This is helpful if you need to free up CPU power for a complex edit
before resuming the export later.
Priority: You can change the background processing priority in Settings > Job
Priority. Setting this to “Low” ensures that your computer remains responsive
for other apps while Shotcut exports in the background. This only affects newly
enqueued jobs, not existing running or pending jobs.

Troubleshooting Failed Jobs
If a job fails:

1. Right-click the job and select View Log.
2. Scroll to the bottom to look for error messages (often related to “Codecs,” “Disk

space,” or “Memory”).
3. Ensure your destination drive has enough free space.
4. If using Hardware Encoder, try disabling it and repeating the job to see if the

issue is driver-related.



Shotcut includes several built-in layout presets designed to optimize the interface
for specific stages of the video production process. These presets automatically
open the most relevant panels and arrange them into logical groups, saving you the
time of manually opening and docking individual views.

Accessing Layouts
You can switch between layouts at any time by going to View > Layout. The
current layout is also indicated by the specialized buttons often found at the top
right of the Shotcut window.

or

Standard Layout Presets
Logging

Focus: Organizing and reviewing raw footage.
Key Panels: Large Playlist and Properties panels.
Usage: Best used at the start of a project to inspect clips, set in/out points, and
categorize media before moving them to the timeline.

Editing (Default)

Focus: General purpose post-production.
Key Panels: Timeline, Filters, and Recent files.
Usage: The balanced, standard view for most trimming, splitting, and
arrangement tasks.

FX (Effects)

Focus: Heavy filter work and keyframing.
Key Panels: Large Filters panel and the Keyframes timeline.
Usage: Provides the detailed view necessary for precise timing of animated
effects and complex filter stacks.

Color

Focus: Color correction and grading.

View > Layout
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Key Panels: Video Scopes (Waveform, Parade, Vectorscope) and the Filters
panel.
Usage: Specifically arranged to give you maximum visual feedback while using
color grading filters.

Audio

Focus: Sound mixing and leveling.
Key Panels: Audio Scopes (Peak Meter, Loudness, Spectrum Analyzer) and
the Timeline.
Usage: Optimized for adjusting track volume, applying audio filters, and
ensuring your project hits target loudness levels.

Player

Focus: Minimalist screening.
Key Panels: Maximized Project Player; hides almost all other panels.
Usage: Used for reviewing your final edit without the distraction of technical
tools.

Managing Custom Layouts
Beyond the presets, Shotcut allows you to save your own favorite workspace
configurations.

Add…: After arranging your panels exactly how you like them, select View >
Layout > Add… to give your configuration a name. It will now appear in your
Layout menu.
Remove…: To delete a custom layout you no longer need, select it from the
menu and choose Remove. (Note: You cannot remove the built-in system
presets).
Restore Default Layout: If your interface becomes cluttered or a panel goes
missing, use this option to reset the current preset to its original “factory” state.

Pro Tip: Layouts are “Snapshots”
When you select a layout, Shotcut applies it as a snapshot. If you move a panel
after selecting “Color,” Shotcut remembers that change for the remainder of your
session. If you want to return to the original “Color” look, simply select the “Color”
layout again from the menu.

See also: Adjusting Panels in the User Interface

https://forum.shotcut.org/t/adjusting-panels-in-the-user-interface/12980/1


The Recent panel provides a convenient history of the media files and project files
( .mlt ) you have recently opened in Shotcut. This panel allows you to quickly revisit
previous work or re-use assets without having to navigate through your system’s
file explorer.

Opening the Recent Panel
If the Recent panel is not visible in your current layout, you can open it using the
following methods:

Toolbar: Click the Recent icon on the top main toolbar.

Keyboard Shortcut: Press Ctrl + 3  (Windows/Linux) or Cmd + 3  (macOS).
Menu: Go to View > Recent.

Features and Interface
1. The Recent List

The panel displays a vertical list of file paths. By default, these are sorted by the
time they were last accessed, with the most recent items at the top. The list
includes:

Project Files: Shotcut project files ( .mlt ).
Media Files: Video, audio, and image files that were opened in the Source
player or added to a project.

2. Opening Items

Double-Click: Double-clicking any item in the list will immediately open that file
in the Source player. If the item is a project file, Shotcut will prompt you to save
your current work before loading the selected project.
Drag and Drop: You can drag items directly from the Recent panel onto the
Source player or Playlist.

3. Searching the List

At the top of the panel is a search bar that allows you to filter the list.

Search (F3): Press F3  while the panel is focused to jump to the search box.
Typing a partial filename or folder path will hide all items that do not match your
query, making it easy to find specific files in a long history.

Context Menu (Right-Click)

View > Recent
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Right-clicking an item in the Recent panel provides the following management
option:

Remove: Removes the selected entry from the Recent list. Note that this does
not delete the file from your computer; it only clears the shortcut from this list.

Settings
You can manage how Shotcut handles your recent file history through the main
settings menu:

Settings > Clear Recent on Exit: When this option is enabled, the Recent list
will be completely wiped every time you close the application. This is useful for
users on shared computers or those who prefer a clean slate for every session.



This was added in version 23.09 to the View menu. It shows all unique and sorted
files in the Playlist and Timeline

This also appears when you drag and drop multiple files to Source, Playlist, or
Timeline that might be problematic - as a way to bulk convert them.

Clicking Convert shows the same Convert to Edit-friendly dialog that you can
reach from the Properties panel.

If you see an exclamation point icon hover the mouse over the icon to see a tooltip
that explains a possible issue.

View > Resources
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The Subtitles Panel was added in Shotcut 24.08

The Subtitles Panel can be used to add subtitles to a project. Subtitles can only be
added to the Timeline. They can not be added to the playlist or clips. We
recommend to save subtitle editing until the timeline editing is complete because
moving or cutting clips on the timeline will break the subtitle synchronization.

Subtitle Tracks
To start editing subtitles, click the “add” button and give the subtitle track and name
and language.

After the subtitle track is created the subtitle track area will appear in the timeline
above the top video track. Multiple subtitle tracks can be added. But only the
currently selected subtitle track is shown in the Subtitle Panel and the Timeline.

Adding Subtitles
Click the “Add subtitle” button to make a new subtitle item at the cursor position.
Then type in the “Current” text area to add the text.

View > Subtitles
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Importing Subtitles
Subtitles can also be imported. Supported subtitle import formats include: SRT,
VTT, ASS, and SSA. Subtitles are imported at the current cursor position.So be
sure to place the cursor before importing subtitles from a file.

Exporting Subtitles
Subtitles can be exported to a file. Subtitles are exported in SRT format.

Embedding Subtitles
When exporting a Shotcut project, subtitles will be embedded in the output file if the
file format supports it. Formats that commonly support subtitles include MKV, MOV
and MP4.
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From the View menu, choose Application Log… to view the log of application
messages. The application log can be useful to reveal potential problems or to give
developers hints about the application performance.

The dialog shows a window with a scrollable view of the application log.

When requesting support on the forum, if can be helpful to click Copy to copy the
contents to the system clipboard and then past the log into a forum post.

Alternately, click Save and save the log to a file which can be uploaded to the
support forum.

Note: The application log is cleared every time Shotcut starts up. When providing
an application log to provide information about a problem, be sure to provide a log
from the same session of Shotcut when the problem occurred. Click Previous to
view the log of the previous session. This is useful if you has to restart or the
application crashed.

View > Application Log
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While the primary panels (Timeline, Filters, Export) are accessed frequently, the
View menu contains several utility items that toggle specific interface elements or
provide diagnostic information about the application.

Interface Toggles
Full Screen

Shortcut: F11
Action: Expands the Shotcut window to cover the entire screen, hiding the
operating system’s taskbar or dock.

Show Title Bars

Action: Toggles the thin bars at the top of each panel (e.g., “Playlist,”
“Properties”).
Usage: Disabling title bars creates a cleaner, more minimalist look. However,
you must enable them if you wish to drag, undock, or close panels using the
mouse.

Show Toolbar

Action: Toggles the main horizontal toolbar at the top of the window.
Usage: Hiding the toolbar can provide more vertical space for the Player or
Timeline, especially on smaller screens. Note that most toolbar functions are
also available via keyboard shortcuts or the main menus.

Show Small Icons

Action: Reduces the physical size of the icons on the main top toolbar.
Usage: If you are working on a laptop or a low-resolution screen, enabling this
option frees up valuable vertical space for the Player and Timeline panels. It is
also a popular choice for experienced users who recognize the icons by sight
and no longer need large targets to click.

Show Text Under Icons

Action: Toggles the text labels (e.g., “Open File,” “Save,” “Export”) beneath the
toolbar icons.
Enabled: Recommended for new users to help learn the interface quickly
without hovering the mouse to see tooltips.
Disabled: Recommended for advanced users or those with limited screen
space. Turning this off significantly thins the toolbar, providing a more
“professional” and minimalist aesthetic.

Other Items in the View Menu
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Utility Panels
History

Shortcut: Ctrl + 8  (Windows/Linux) / Cmd + 8  (macOS)
Description: Opens a list of every action taken in the current session (e.g.,
“Split clip,” “Change filter”).
Usage: You can click on any previous state in the list to “undo” multiple steps at
once. The history is cleared every time you close Shotcut.

Notes

Shortcut: Ctrl + Shift + 3  / Cmd + Shift + 3
Description: Provides a simple text area to type reminders, project to-do lists,
text to be converted to generated-audio speech, or script notes for voiceovers.
Usage: These notes are saved directly into your .mlt  project file.

Resources

Description: Displays a list of all unique media files currently used in the project
(both in the Playlist and on the Timeline).
Usage: Useful for identifying “missing” files or bulk-converting problematic
variable-frame-rate files to “Edit-Friendly” formats.

Diagnostic Tools
Application Log

Description: Opens a text window showing the background technical activity of
Shotcut.
Usage: If Shotcut crashes or behaves unexpectedly, developers on the Shotcut
Forum will often ask for this log to help diagnose the issue. You can use the
Save button to export the log to a text file.
Use the Previous button to view the log of the previous session. For example, if
Shotcut crashed, restart, choose View > Application Log, and click Preview to
view the log of the session that crashed.

https://forum.shotcut.org/


This feature provides a unified action search and shortcut editor. Action search
makes it quick to find and execute a command. It also provides a keyboard shortcut
reference and lets you add or change shortcuts.

The Actions and Shortcuts Window was added in version 22.09.23.

The window can be accessed by going to Help > Actions and Shortcuts.
The window can also be accessed by the default shortcut keys ?  and / .
Searches both action name and shortcut.
Press Return / Enter  within the search box to move focus to the list of
actions.
Press Return / Enter  on a selected Action to trigger it and close the dialog.
Shift , Ctrl , or Alt  + Return / Enter  on a selected action to

trigger it and NOT close the dialog.
Double-click an action to trigger it but NOT close the dialog.
The dialog is not modal so you can leave it open and to the side while working.
Press Esc  when the dialog has focus to close it.

Press F2  when an action is selected to edit its first shortcut.
Single-click a selected shortcut to enter edit mouse using the mouse. This
means you typically need two single clicks: one to select, the second to enter
into edit mode.
You can Tab  out of edit mode to navigate focus to the apply button and press

Space  to trigger the apply. It is intentional that you cannot assign Tab  as a
keyboard shortcut to an action.
There are some keyboard buttons such as J/K/L that are reserved and cannot
be used in a shortcut. You will see an error message when you try to apply it.

Help > Actions and Shortcuts
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You can define up to 2 shortcuts per action! You may want to leave the default
as well as add your preferred shortcut.



Shotcut features a highly flexible, dockable user interface based on the Qt
framework. This allows you to rearrange, resize, stack, or even float panels to
create a workspace that fits your specific hardware (such as dual monitors) and
editing style.

Key UI Components
The interface is composed of several functional panels including the Playlist,
Filters, Properties, Timeline, and various Scopes. You can toggle these on or off
using the View menu. The main toolbar buttons either open the panel or if it is in a
background tab, brings that tab to the front.

Resizing Panels
You can change the amount of screen real estate dedicated to any panel by
dragging its edges. Hover your mouse over the border between two panels. The
cursor will change to a double-headed arrow. Click and drag to resize both panels
simultaneously.

Moving and Reordering Panels
Each panel (except the central player) has a title bar. You can use this to move the
panel to a new location.

To Move: Click and hold the title bar of a panel, then drag it toward another area
of the screen.
Drop Zones: As you drag, you will see blue “drop zones” appear.
Edge Zones: Dropping here will snap the panel to the side, top, or bottom of an
existing panel.
Center Zone: Dropping in the center of an existing panel will create a Tabbed
Group.

Tabbed Groups
To save space, you can stack multiple panels in the same area.

Accessing Tabs: When panels are grouped, tabs appear at the bottom or top of
the panel area. Click a tab (e.g., switching between “Playlist” and “Filters”) to
bring that panel to the front.
Reordering Tabs: You can click and drag the tabs themselves to change their
left-to-right order.

Floating and Undocking Panels

Adjusting Panels in the User Interface
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If you use multiple monitors, you may want to move certain panels (like Scopes or
the Timeline) to a second screen.

Undock: Click the “undock” icon (two overlapping boxes) in the panel’s title bar,
or simply drag the panel completely outside of the main Shotcut window.
Redock: Drag the floating window back over the main Shotcut interface until a
blue drop zone appears, then release.

Hiding and Showing Title Bars
For a cleaner look, you can hide the title bars of all panels.

Menu: Go to View > Show Title Bars to toggle them.
Note: You must have title bars visible to move or close panels using the mouse.

Closing Panels
If your workspace becomes cluttered, you can close any panel you aren’t using.

Method 1: Click the X in the corner of the panel’s title bar.
Method 2: Toggle the panel off in the View menu or the main toolbar.
Method 3: Use the dedicated keyboard shortcut (e.g., Ctrl+6  for Filters).

Restoring the Layout
If your interface becomes disorganized or a panel “disappears,” you can quickly
return to a known state.

Restore Default: Go to View > Layout > Restore Default Layout.
Presets: Shotcut includes several specialized layout presets such as Editing,
Audio, Color, and FX. These can be found under the View > Layout menu.



Introduction
Video Mode is the project resolution, aspect ratio, frame rate, and color space. It
is important to set this as you desire at the beginning of your project. If you try to
change it later Shotcut will try to retain the timing of edits, but some users have
reported problems, and it is risky. Also, at this time Shotcut will not automatically
adjust anything for you related to size and positioning of elements like text and
picture-in-picture when changing resolution. You can think of this like the page size
in a word processor or the canvas size in a drawing program.

Broadcast vs. Non-Broadcast
Shotcut includes a number of video modes that are compatible with broadcast
standards and thus the Blackmagic Design SDI/HDMI integration if you have that.
These are also simply the most popular choices as well:

How to read these:

HD = high definition (resolution)
SD = standard (low) definition
UHD = ultra-high definition (UHD 2160 is the 4K variant of UHD)
the first number is the vertical resolution (number of lines or rows)
the second number is the number of frames-per-second (fps)
p  after the first number means progressive scan

Settings > Video Mode
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i  after the first number means interlaced

If you go to the Non-Broadcast sub-menu, there are a number of useful
alternatives including trendy square and vertical resolutions:

Custom
In the bottom Custom sub-menu, you can Add… your own:

If you give your mode a name, it will be saved in the Custom sub-menu.
Otherwise, you can defined something for the current project only.

The maximum resolution is 8192 x 8192. Only even numbers are accepted
because most video codecs only support even values.

Click the down arrow at the end of Frames/sec to pick from some popular frame
rates. Due to some weird legacy video stuff, most often something that is called 30
or 60 fps is actually slightly less. The exact numbers are achieved through fractions
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3000/1001 and 60000/1001. In order to express those in Shotcut, it is important to
use enough decimal digits. 29.97 or 59.94 is not considered precise enough
because there are some devices and tools that use these exact values instead of
the fraction values. Then, this imprecision affects Shotcut’s Automatic video mode
and export. Some people do not want their source video frame rate uncontrollably
altered at export. Thus, Shotcut only really uses 30000/1001 when you use
29.970030 and 60000/1001 when you use 59.940060. These special values are
conveniently available in this drop-drown menu.

There are many colorspace standards for video, but at this time Shotcut only
supports ITU-R BT.601, which is typical for SD, and ITU-R BT.709 for just about
everywhere else except HDR.

Of course, after adding a custom video mode, you can use Settings > Video Mode
> Custom > Remove… to remove it:

Simply click the checkbox next to the name or double-click the row until you see
the check appear and click OK.

Automatic
Automatic means the resolution and frame rate will be based on the first file you
add to your project. If the first file is not a video clip (for example, image or audio),
then the video mode will be 1920x1080p 25 fps This is not necessarily the first clip
currently in the Playlist or Timeline. Again, it is the first file you open and then add
to the playlist or timeline. Therefore, it almost always recommended to wisely
choose a video clip first when you use Automatic. If you are making an image
slide show, you may find the default 1080p25 adequate. If not, then set your video
mode! If you are only doing audio editing, then it does not matter much except
higher frame rate gives you greater precision in edits.

Project vs. Settings
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Once you start a project, the current Video Mode is adopted (not Automatic) or
determined (Automatic). Then, when you load a project, the Video Mode in the
Settings will be checked if it matches your project. Otherwise, if a match is not
found Automatic is checked. (Versions before 20.06 did NOT change its checkmark
to indicate the project’s mode.) You can also see the video attributes of a currently
opened project - assuming it is using the Timeline - click Output (this was named
“Master” in versions before 20.06) in the top left corner and view Properties.

You can change the project video properties by choosing a Video Mode in the
Settings menu; However, as mentioned above, be careful with this because
Shotcut will not automatically adjust anything for you related to size and positioning
of elements.
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This sub-menu chooses how Shotcut does its image processing after reading a
video or image and before displaying or exporting it. It shows these options:

Native 8-bit CPU (fast, flexible)
Native 10-bit CPU (slower, better)
Linear 10-bit CPU (slowest, best)
Linear 10-bit GPU/CPU (Experimental)

This was added in version 25.12 and replaces the old menu item Settings > GPU
Effects. Previous versions of GPU Effects did not process the image in linear color
when using CPU filters; since version 25.12 it does.

10-bit Video

Bit depth is the number of colors or video brightness levels. 8-bit has only 256
values per color component, for example, red/green/blue. 10 bits has 1024 levels.
Previously, 10-bit video sources were only partially supported using GPU Effects
and only GPU filters. Without GPU Effects (CPU), in order to stay in the 10 bit
space, you could only use filters with the #10bit  tag but no transitions or track
blending/compositing. Now, we have ported many CPU video effects to support 10-
and 12-bit video sources including transitions and track blending. Also, the #10bit
CPU video filters also work properly with the experimental GPU processing. Not all
of the video CPU filters have been converted; many of them come through another
software project that does not support it. However, we were able to convert many
for this release or at least mark them as safe for a 10-bit project.

The filters menu Video button shows a drop-down to choose a suitable filter for
either 10-bit and/or GPU processing pipelines:

Settings > Processing Mode
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Linear Color Processing

Any mixing of pixels with a color space’s gamma is not ideal, can cause color
distortions, and is technically incorrect. This pixel mixing occurs whenever images
interpolated, for example scaling, blurring, and sub-pixel positioning, as well as with
track blending/composition. Previously, only GPU Effects and video filters in the
GPU category operated in linear color. Now, there is an option to use it outside of
the GPU processing.

There is no linear option for 8-bit because that naturally causes quantization
artifacts. There are not enough bits available to show enough levels for the portions
that the human eye is most sensitive.

Non-linear “native” options are still included because there is a signficant
performance decrease when using linear (more conversions). We have a plan to
improve performance for the next release. 8-bit is still included because it is more
“flexible” by including more video filters. Of course, you can use an 8-bit video filter
in a 10-bit, but the quality of the video clip or track will suffer a reduction in bit
depth.



This is a project setting that controls the number of audio channels you want to use
in your project. The default is 2 channel stereo, which suffices most people. You
can choose 6 (5.1) for surround sound, but Shotcut does not yet support a variety
of surround channel layouts.

For 6 channels, Shotcut uses the FFmpeg default channel layout for 6 channels:
Front Left, Front Right, Front Center, LFE, Surround Left, Surround Right

Settings > Audio Channels
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The Preview Scaling setting may be used to reduce the resolution of video
processing when you are using a fair amount of filters, transitions, and track
blending. This may help with the performance during the editing process.

However, keep in mind that the source video or images must typically be scaled
down to the designed preview scale, and that will have a processing cost. See
Settings > Proxy Editing for the remedy to that. Proxy generates substitute clips
at the same resolution as preview scale to eliminate the overhead of this scaling.

The submenu lists only the vertical resolution. The horizontal resolution depends on
the aspect ratio of your project.

360p is a good choice on a 1080p screen or less
540p is good choice when working on a high density screen or screen with
resolution > 1080
720p is a good choice when working on a 4K screen or with 4K UHD footage
and you want to get a
little more clarity

Preview Scaling was added in version 20.02.

Export
Export > Advanced > Video has the option Use preview scaling.

Settings > Preview Scaling
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This is intended to provide a faster export for draft review. You should leave the
export resolution set to the project resolution unless your preset or video codec
dictates a resolution.

Caveats
The Stabilize video filter disables preview scaling for the clip on which it is
applied because it is incompatible.
Preview scaling is a step further away from WYSIWYG (what you see is what
you get) and does not provide perfect fidelity and full precision. Some
differences are unavoidable especially where blur, softness, and noise are
concerned.
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Introduction
Proxy editing is the process of creating and using low resolution videos and images
in places of the original or optimized (Convert to Edit-friendly) files. This provides
the advantage that your computer has less work to do in realtime while editing:
decoding, scaling, and effects. This is, quite simply, because there are less pixels
to compute. Then, when you are ready to export, it will use the original (or
optimized) files for full quality.

Performance is optimal when the preview resolution matches the files it is working
with. So, this feature is designed to work in conjunction with Preview Scaling. You
can still use the proxy mode without Preview Scaling, however, in case something
is not working absolutely correct with Preview Scaling.

Proxy editing was added in version 20.06.

The format of a proxy file can be hotly debated because they typically have a
number of goals that is difficult to achieve simultaneously: low resolution, small file
size, fast to generate, fast to seek and decode, and decent image quality to do
understand your work. Not everyone has these goals, but these are Shotcut’s
goals, and the format is not configurable. If you do not like how Shotcut generates
proxy files, you can still create them with a different process (including Shotcut) if
you understand where proxies are stored and how they are named. You are not
required to use the MP4 file format for videos, but the name must end with .mp4  for
video and .jpg  for images. Shotcut can almost always handle a video file whose
name does not match the format (but almost never for an image). Fortunately, most
people will be happy with JPEG for a proxy image even if not happy with our choice
of MP4. A convenience of MP4 is that most media players can play them making it
convenient when troubleshooting proxy files.

Settings > Proxy > Use Proxy
This either turns on or off the usage of proxy files for either the current project or
the next project you open or start. When you turn this on and open a project,
Shotcut looks for proxy files that already exist on your file system and uses them
automatically and dynamically. However, it does not automatically
generate a proxy file at this point if there are any missing. Any files added to the
Playlist or Timeline will, however, generate a proxy file if one does not exist
according to the following rules:

It is a video (optionally with audio) or an image file.
It is not an image sequence.
It does not have an alpha channel (transparency).

Settings > Proxy Editing
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The video is not only cover art.
It does not already have a proxy.
Proxy for this file has not been disabled in Properties.
Both the image width and image height are more than 1.3X the preview scaling
resolution (or 540 if preview scaling is off).
A proxy job for this file was not yet created.

It generates a proxy by queuing a job in Jobs. You can continue working with the
original at this point. When this proxy job completes, it uses the Replace command
to asynchronously update matching clips in Source, Playlist, or Timeline. In doing
so, it tries very hard to retain all changes thus far including trimming, filters, and
transitions. The vertical resolution of the proxy will be the same as your current
Preview Scaling resolution. If Preview Scaling is set to None, then it uses 540p.
The width of the proxy will be whatever matches the display aspect ratio for
the target height.

If you turn off proxy with a project opened, Shotcut automatically reopens the
project. This causes it to no longer look for proxies during reopen, but it does take
time for the project to reload, it clears undo history, and it resets selected clips. It
does this without requiring you to save your current project,
however.

If you turn on proxy with a project opened, Shotcut also automatically reopens the
project as well while locating whatever proxies are currently available. Then, it
prompts if you want to generate proxies for files that do not currently have them
subject to the same rules above. These proxy jobs will not do a replace operation
as they complete successfully. As the Replace command is still immature, we do
not want someone to open a big old project, generate proxies for nearly everything
and have it murder your project! Rather, once all of the jobs are done, reopen the
project to pick up the proxies.

Settings > Proxy > Storage
Proxy files can be stored in one of two locations: a global folder or a project folder.
When opening a project, it looks in both places. The global folder defaults to a sub-
folder named “proxies” of your App Data Directory. The project folder is a sub-folder
named “proxies” of a project folder created with New
Project > Start on Shotcut’s startup screen.

Choose Settings > Proxy > Storage > Set to change your global project folder to
a new location.

Choose Settings > Proxy > Storage > Show to open a folder view from your
operating system’s file manager to see which folder is currently in use. This is
where newly generated proxies are saved. The result of this action depends on
whether you have a project currently opened or started and whether it has a project
folder.
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Choose Settings > Proxy > Storage > Use Project Folder to control whether you
want proxies to be generated in a project folder, if in use, or always in the global
folder.

Settings > Proxy > Hardware Encoder
You have the option to use your configured hardware encoder to generate proxies.
The lead developer of Shotcut has not found much of an advantage in using it for
these low resolution files if you have a strong CPU. Some systems with a weak
CPU and compatible GPU may benefit from using it. For most users, do not expect
it to significantly improve the speed. Since most hardware encoders tend to create
larger files for the same quality as a software encoder, it uses HEVC to keep the
file size reasonable. With that said, do not expect them to be much smaller than the
software-generated H.264. In fact, they are going to be slower to decode. Still, it is
there for your option and experimentation.

Properties
The Properties panel for video clips and images display (PROXY) next to the
resolution when it is using a proxy file. You may also notice that Properties shows
information about the proxy file instead of the original/converted except for the clip
name, duration, frame rate, aspect ratio, and color range. Properties should
continue to reflect any overrides where possible.

The Properties panel also has a Proxy menu button with the following options:

Make Proxy - forces a proxy to be generated without adhering to the rules
above. If you choose not to batch convert a project to proxies, use this to
selectively generate proxies. The proxy job this generates will do a replace
operation.
Delete Proxy - Unfortunately, this is not available on Windows due to file locking
prevents it from working (file is likely in use). Otherwise, this does what it says.
Disable Proxy - prevents a proxy from being generated for this file. It only
applies within the current project and not globally. Also, replaces all matching
clips in the project with the original if it using a proxy. Re-enabling does not
create or replace with proxy; you need to either reopen the project (if proxy
exists) or choose Make Proxy.
Copy Hash Code - shows a dialog with a 32 character alpha-numeric code that
has also been copied to the system clipboard. This is helpful to track down
problems with proxy files or to generate proxy files externally.

Export
Normally when you export, the proxy clips are replaced with their original or
converted. However, if you go into Advanced mode and turn on Video > Use
preview scaling, not only does export use the preview scaling resolution, but also



it uses proxy clips and images to further speed up export! This is intended to more
quickly make a rough draft for review, not as a final output, of course.

Known Problems
1. A proxy can hide a problem with the actual source media, for example, frame

accurate seeking on video.

2. There is no obvious way to add a proxy to a clip-only project. It is by design not
to load or create a proxy until you add it to the playlist or timeline since the
Source player can be used to quickly preview clips to decide whether to use
one. However, it is possible. If you know the proxy already exists, you can save
the project and reopen it to pick it up. Otherwise, choose Properties > Proxy >
Make Proxy.

3. File > Export Frame… exports using the proxy up-scaled to project resolution it
since uses the current image from the player.

4. It does not work with File > Open MLT XML As Clip. It does not replace the
clips in the sub-project with proxies.



Scrub Audio was added in version 15.09

In Shotcut, the audio is muted by default when you:

Drag (scrub) the Playhead in the Timeline
Move the Playhead forward or backward frame by frame (with the left/ right
arrow keys, or the mouse wheel on the Timecode)
Increase the playback speed (forward or backward)

The Scrub Audio feature allows you to hear the audio while navigating through your
timeline. This can be useful for precise audio editing and synchronization.

To enable/disable Scrub Audio:

Go to Settings > Player.
Check/uncheck the Scrub Audio option.

Settings > Player > Scrub Audio
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Settings > Player > Use JACK Audio
JACK (Jack Audio Connection Kit) is a low-latency audio system widely used on
Linux in media workflows. It is designed for applications that require precise timing,
flexible audio routing, and reliable synchronization.

When Use JACK Audio is enabled, Shotcut can:

Participate in a JACK-based audio environment
Shotcut’s audio output becomes available in the JACK graph, allowing it to be
connected to other JACK-compatible tools such as digital audio workstations,
audio processors, or monitoring utilities.

Provide advanced audio routing control
JACK offers a centralized way to manage audio connections across applications
and devices. With a JACK control tool (for example, QjackCtl), users can
explicitly route audio to specific physical outputs or processing chains, which can
be difficult to achieve with standard desktop audio systems.

Provide transport synchronization with other applications
Transport control is playback control such as pause, play, rewind, fast forward,
and seek. JACK lets applications that opt into this to control each other’s
playhead and playback. Obviously, this only works well when there are similar
projects in each application. For example, one can do the video editing in
Shotcut without audio do and all of the audio work for the same movie in a digital
audio workstation (DAW). Run both at the same time, possibly on different
screens, and load the respective projects for the same super-project (your
movie). Now, when you seek, scrub, or play the video in Shotcut the
corresponding audio project in the DAW plays at the correct time as well.

This option is intended for Linux and macOS users who already have the JACK
audio system installed and running.

Purpose
Enables Shotcut to connect to the JACK audio server if your JACK setup does
not allow sharing the audio device.
Allows precise audio routing and transport control between Shotcut and other
JACK-aware applications!
May provide lower latency compared to standard system audio backends.

Behavior
When Use JACK Audio is enabled:

Settings > Player > Use JACK Audio
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Shotcut sends and receives audio through JACK
Audio ports appear in JACK patch bays (e.g. qjackctl, Helvum)
Audio routing is handled externally by JACK
System audio devices are no longer managed directly by Shotcut

When disabled:

Shotcut uses the default system audio backend (e.g. PulseAudio / PipeWire)

Typical use cases
Professional audio workflows
Synchronizing Shotcut with DAWs or audio tools (e.g. Ardour)
Advanced audio routing and monitoring
Low-latency audio playback and capture

Requirements and notes
A running JACK server is required
If JACK is not running, enabling this option may result in no audio
Audio connections must be managed manually using a JACK control tool
Not required for standard editing or playback

Limitations
Not available on Windows
No effect unless JACK is installed and running
Increased complexity compared to default audio handling
Not intended for casual or beginner workflows



This option affects playback and controls two things:

1. when ON: drop some video frames to try to keep the audio continuous and keep
the video running near real-time
This can make the video to appear choppy or slower frame rate than expected
when it is on. Even when this is on it is possible that video processing is so
intense that audio becomes choppy as well because Shotcut will not drop video
frames indefinitely. In fact, currently it will only drop 5 consecutively (subject to
change). Turn this off if you want to see every video frame regardless of how
slow it goes or choppy the audio becomes.

2. when OFF: use multiple threads for image processing (filters, transitions, and
track blending/compositing). Turn this setting off if you want to see if multiple
threads can reduce some choppy playback or lag.

Additional Notes
When this is option is off it turns on the same thing as Export > Advanced >
Video > Parallel processing.
Shotcut will use up to 4 background threads to render 4 video frames at the
same time.
Sometimes, this is the cause of a malformed image, which should be reported
so it can be debugged.
This is in addition to image slice-threaded processing used in many effects. The
number of these threads is typically the same as the number of CPU threads.
These threads do not consume nearly as much memory.
The rule for the number of frame threads:

# CPU threads # Shotcut threads

> 4 4
4 3
3 2
2 1
1 1

Settings > Player > Realtime (frame dropping)
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Controls how interlaced video is presented in the Shotcut player.

This option affects preview display only. It does not modify clips, timeline data, or
export output.

The default is ON.

What “Progressive” means
Progressive video displays each frame as a complete image drawn in a single
pass.

This contrasts with interlaced video, where each frame is composed of two
alternating fields captured at different times. Interlacing was historically used in
analog television systems to reduce bandwidth and improve perceived motion on
CRT displays.

Common interlaced formats included:

480i (NTSC)
576i (PAL / SECAM)
1080i (HD broadcast)

Modern displays are progressive by nature and must convert interlaced material
before showing it.

Settings > Player > Progressive
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What the Progressive option does
When Progressive is enabled:

Interlaced footage is shown as full progressive frames
Field separation and combing artifacts are reduced or removed
Motion appears cleaner and easier to evaluate

Note:

When Progressive is enabled, the Deinterlacer setting determines how
interlaced video is converted to progressive frames for preview.

When Progressive is disabled:

Interlaced footage may be displayed closer to its raw field-based structure
Field artifacts (combing, line flicker) can be visible on motion
Preview reflects the interlaced nature of the source more directly

Important scope clarification

This setting affects player preview only.

It does not:

Change source media
Alter clip or timeline properties
Force progressive export
Apply deinterlacing to the final output

Export behavior is controlled separately.

Visual characteristics
Progressive enabled

Cleaner motion
No visible field separation
More readable preview on modern displays

Progressive disabled

Possible combing on motion
Visible interlacing artifacts
Closer representation of raw interlaced fields

Recommended usage
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Enable Progressive for most modern workflows

Especially useful when working with:

Interlaced broadcast recordings
PAL / SECAM / NTSC archival footage
Legacy television material

If you disable Progressive to more directly view the interlacing, then you might
also want to set the player zoom to 100% to prevent fields from mixing when
scaling.

Limitations and notes
This is a preview-only setting
It does not replace proper deinterlacing during export
It does not convert interlaced footage to progressive media
Final output quality depends on export configuration



Selects the algorithm used to convert interlaced video to progressive for
display in the Shotcut player.

This setting affects preview quality and performance only.
It does not modify clips, timeline data, or export output.

Historical context
Interlacing originated in early analog television systems as a way to reduce
bandwidth usage while maintaining acceptable motion smoothness on cathode-ray
tube (CRT) displays. By transmitting alternating fields instead of full frames,
broadcasters could double the perceived refresh rate without increasing signal
bandwidth.

As display technology evolved, flat-panel screens (LCD, LED, OLED) became
standard. These displays are inherently progressive and cannot show interlaced
fields directly. As a result, interlaced video must be converted into progressive
frames for proper viewing.

Deinterlacing exists to bridge this gap between legacy interlaced formats (such as
PAL, SECAM, NTSC, and 1080i broadcast video) and modern progressive
displays.

What Deinterlacing is
Interlaced video stores each frame as two fields captured at different times.
Deinterlacing reconstructs those fields into a single progressive frame suitable for
modern displays.

Different deinterlacing methods trade quality, motion accuracy, and performance.

Settings > Player > Deinterlacer
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Scope and behavior
Applies to player preview
Option is always selectable, regardless of the Progressive setting
Has no effect on exports
Does not alter source media

The selected method defines how interlaced content is processed when displayed.

Deinterlacer options
One Field (fast)

This is the default. It uses only one field to build each frame.

Very fast
Half vertical resolution
No motion blending

Visual result

Stable motion
Softer image
Reduced detail

Use when: performance is critical or hardware is limited.

Linear Blend (fast)

Blends the two fields together into one frame.

Fast processing
Simple averaging

Visual result

Reduced combing
Motion blur on movement
Loss of sharpness

Use when: quick preview with fewer visible artifacts is acceptable.

YADIF temporal only (good)

Motion-adaptive deinterlacing using temporal information (differences between
frames).

Preserves more detail
Balanced quality and performance

Visual result



Cleaner motion
Fewer artifacts than blending

Use when: regularly previewing interlaced footage.

YADIF temporal + spatial (better)

Uses both temporal and spatial analysis.

Improved edge reconstruction
Higher processing cost

Visual result

Sharper edges
Cleaner motion

Use when: preview quality is more important than performance.

BWDIF (best)

Advanced deinterlacing algorithm designed for high-quality reconstruction.

Best motion handling
Highest detail preservation
Most computationally expensive

Visual result

Smooth motion
Minimal artifacts

Use when: inspecting interlaced footage carefully, archival work, or quality-critical
review.

Performance considerations

Method Quality Performance

One Field Low Very fast
Linear Blend Low–MediumFast
YADIF (temporal) Medium Moderate
YADIF (temporal + spatial)High Slower
BWDIF Highest Slowest

Limitations
Preview-only setting
Does not replace export deinterlacing
Higher-quality methods may reduce playback performance



No effect on progressive sources



Controls how Shotcut resamples images during player preview when video is
scaled, repositioned, or rotated.

This setting affects preview quality only. It does not change clips, timeline data, or
exported files.

What interpolation is
Interpolation is the computation of new pixel values based on neighboring pixels
when an image does not align exactly with the pixel grid.

In practical terms, it affects:

Scaling (zooming in or out)
Sub-pixel positioning
Rotation
Motion that places pixels between pixel boundaries

Because pixels cannot be partially drawn, interpolation determines how smooth or
sharp the result looks. This is sometimes described as sub-pixel rendering.

Scope and behavior
This setting applies only to the player preview.

It does not:

Affect export quality
Change render output
Modify source media
Apply to text, SVG, or HTML rendering

A separate interpolation setting exists in Export > Advanced > Video.

Interpolation options
Nearest Neighbor (fast)

No interpolation is performed.

Uses the closest existing pixel

Settings > Player > Interpolation

https://en.wikipedia.org/wiki/Nearest-neighbor_interpolation
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No averaging or smoothing
Fastest option

Visual result

Sharp but blocky
Visible pixel stepping
Jagged edges when scaling or moving

Use when: performance is critical or when pixel-perfect preview is desired.

Bilinear (good)

This is the default. It interpolates using the four nearest pixels.

Simple averaging
Moderate smoothing
Low computational cost

Visual result

Softer than Nearest Neighbor
Reduced jagged edges
Slight blur

Use when: general editing with good performance.

Bicubic (better)

Interpolates using a larger neighborhood of pixels.

More complex averaging
Better edge preservation
Higher processing cost

Visual result

Sharper than Bilinear
Fewer artifacts
More natural scaling

Use when: preview quality matters more than speed.

Lanczos (best)

High-quality interpolation using a wider sampling window.

Preserves fine detail
Best edge reconstruction
Highest processing cost

Visual result

https://en.wikipedia.org/wiki/Bilinear_interpolation
https://en.wikipedia.org/wiki/Bicubic_interpolation
https://en.wikipedia.org/wiki/Lanczos_algorithm


Very sharp
Minimal blur
Possible ringing on high-contrast edges

Use when: inspecting image quality or doing precision work.

Performance considerations

Method Quality Performance

Nearest NeighborLow Very fast
Bilinear Medium Fast
Bicubic High Slower
Lanczos Highest Slowest

Usage notes
Higher-quality interpolation improves visual clarity, not export quality.
On slower systems, Lanczos may reduce playback responsiveness.
This setting does not affect:
Text anti-aliasing
SVG rendering
HTML content



Adjusts audio/video playback alignment in the Shotcut player to compensate for
synchronization differences during preview.

This setting affects player playback only. It does not modify clips, the timeline, or
exported files.

What synchronization means
Audio/video synchronization (often called lip-sync) describes how accurately sound
and image are aligned in time.

When synchronization is off, viewers may notice:

Speech not matching mouth movement
Sounds occurring slightly before or after visual events

Such offsets can be caused by:

Audio hardware latency
Video decoding delay
Driver or system timing differences

Parameter
Video Offset (-250 ms to +250 ms)

Shifts the video playback timing relative to the audio during preview.

0 ms
Audio and video play as decoded, with no adjustment.

Negative values (-)
Video is displayed earlier relative to audio.
Use when video appears late.

Positive values (+)
Video is displayed later relative to audio.

Settings > Player > Synchronization

https://d2t917e3b1b2xy.cloudfront.net/original/3X/f/b/fbf7e6b2dc06c6e1afa365c5d7b77eb1857f0409.jpeg
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Use when audio appears late.

Important note:

The adjustment is expressed in milliseconds (ms).

How to use this setting
1. Play a clip with clear audio cues (speech, claps, impacts).
2. Observe whether sound or image leads.
3. Adjust Video offset until audio and visual events align naturally.

This is especially useful when monitoring on systems with known latency.

Scope and behavior
This setting affects player preview only.

It does not:

Alter clip timing
Shift audio or video on the timeline
Affect exports or renders
Correct sync issues in the source media

Any adjustment made here is temporary and non-destructive.

Recommended usage
Correcting preview sync issues caused by audio interfaces
Compensating for Bluetooth or external audio device latency
Improving lip-sync accuracy during editing

If sync problems persist in exported files, they must be addressed on the timeline
or during export, not here.

Limitations
Preview-only adjustment
Global setting (not per clip)
Does not fix incorrectly synced source media
Not a replacement for proper timeline alignment

See also: Audio/Video Properties to learn how to adjust a sync problem with a
clip

https://forum.shotcut.org/t/audio-video-properties/12923/1


The Rectangle Selection tool, introduced in version 23.11.29, allows you to use
your mouse to select a single clip or a group of clips in the Timeline.

The tool is enabled by default.
To disable or enable it, go to Settings > Timeline

There are a few supported actions for multiple selection:

Copy
Cut
Lift
Move to another place in the Timeline
Ripple Delete
Split (version 24.01 and up)
Apply Copied Filters

Shortcuts

When the tool is disabled, hold Shift  to enable it temporarily

When the tool is enabled, hold Shift  to disable it temporarily

Settings > Timeline > Rectangle Selection

https://shotcut.org/blog/new-release-231129/
https://shotcut.org/blog/new-release-240128/
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This timeline option was added in version 23.11. This option automatically adds an
empty audio or video track to have ready so you do not need to add them manually.
An empty track also helps to provide some space in order to select by dragging a
box or rectangle or to provide more area for scrubbing.

It only adds tracks when you add something to the timeline or move a clip between
tracks. Also, it does not automatically add a track when you open a project with no
empty tracks.

In addition, this can be helpful to new or infrequent users who do not know you
need to add an audio track or how to do that to add music. Or that you need to add
a video track to overlay an image or video on top of another.

Settings > Timeline > Automatically Add Tracks

https://forum.shotcut.org/


This is a sub-menu in Settings > Timeline that was added in version 23.09 with
the following options:

Center the Playhead - you can still move the playhead before the center point.
But during playback, when the playhead reaches the center, it stops moving and
the timeline starts scrolling in a smooth fashion.
No - no automatically scrolling
Page - when the playhead reaches the end of the timeline panel, the timeline
suddenly scrolls by nearly the width of the timeline panel and stops scrolling until
the playhead reaches the end again. This seems to be the most common among
video editing tools - except perhaps by the page size.
Smooth - the traditional behavior of Shotcut: when the playhead reaches the
end of the timeline panel, it remains there and the timeline starts scrolling
smoothly.

Scroll to Playhead on Zoom is a checkbox separate from the above options. This
controls whether Shotcut scrolls the timeline to keep the playhead within view after
changing the timeline level of zoom.

Settings > Timeline > Scrolling

https://forum.shotcut.org/


This setting is only available on Linux.

Shotcut uses OpenGL technology to draw its user interface and display video.
OpenGL is typically implemented in the GPU of your computer and its driver in the
operating system. These two pieces (Shotcut and the UI library it uses) and the
OpenGL implementation need to communicate using a complex protocol.
Sometimes, they do not communicate well and have compatibility or interoperability
problems. Thus, there are some workarounds:

use only software using a library called Mesa 3D. While this is known to be very
compatible, it is much slower since it is not hardware-accelerated.
on Windows, convert the OpenGL protocol to DirectX (Direct3D) using a library
called ANGLE. While this is typically hardware-accelerated, Microsoft provides
an automatic software fallback of its own called WARP.

If you choose Automatic, Shotcut’s UI library chooses one of the options based on
the model of your GPU, and usually that is OpenGL. You can see what Shotcut is
using by looking in View > Application Log… from the main menu. Then, after
about 100 lines, look for the lines start with

[Info ] Mlt::GLWidget::initializeGL

If you see the following, then it is using DirectX:

[Info ] Mlt::GLWidget::initializeGL OpenGL vendor “Google Inc.”
[Info ] Mlt::GLWidget::initializeGL OpenGL renderer "ANGLE…

If you see the following, then it is using Software:

[Info ] Mlt::GLWidget::initializeGL OpenGL vendor “VMware, Inc.”
[Info ] Mlt::GLWidget::initializeGL OpenGL renderer “Gallium 0.4 on llvmpipe
(LLVM 3.4, 256 bits)”

This setting corresponds to the key opengl  in the configuration file or registry.

See also
https://wiki.qt.io/Qt_5_on_Windows_ANGLE_and_OpenGL#ANGLE_Project

Settings > Display Method

https://chromium.googlesource.com/angle/angle/+/master/README.md
https://shotcut.org/notes/configuration/
https://wiki.qt.io/Qt_5_on_Windows_ANGLE_and_OpenGL#ANGLE_Project
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The App Data Directory is where Shotcut stores:

automatically saved project files in the autosave  sub-folder
builtin and saved generator, filter, and export presets in the presets  sub-folder
custom video modes in the profiles  sub-folder
thumbnails and waveforms in the thumbnails  sub-folder
non-project-specific proxy videos and images in the proxies  sub-folder
favorited transition wipes in the transitions  sub-folder
db.sqlite3  is a database where thumbnails and audio levels for waveforms are
saved. (This database provides a more cross-platform way to order things by
access/read time than a file system.)
shotcut-log.txt  which is a log file of messages from the Shotcut programming
code, also viewable within the application through View > Application Log…
This is overwritten on every run of Shotcut. Thus, if Shotcut is failing to start,
there might be a clue in this file.
optionally shotcut.ini  if you used Settings > App Data Directory > Set… or
command line option --appdata  to store Shotcut’s various settings or
configuration. The idea here is that the app data directory can be placed in a
portable location such as USB stick or network file share. Also, some people find
it easier to locate and edit than the registry on Windows, plist on macOS, or
~/.config/Meltytech/Shotcut.conf file on Linux.

Use Set… ( Settings > App Data Directory > Set… ) to change the location of the
app data directory to make the Shotcut configuration and helper files portable (USB
stick) or usable from multiple systems (network file share).

Use Show… ( Settings > App Data Directory > Show… ) to open the folder in your
OS file manager (Explorer on Windows, Finder on macOS).

Settings > App Data Directory

https://shotcut.org/notes/command-line-options/
https://shotcut.org/notes/configuration/
https://forum.shotcut.org/


Settings > Job Priority
Low: Default (Recommended)
Normal: Option to improve performance on Intel 12th generation CPUs with E-
cores.

Introduced in version 22.01.30.

Settings > Job Priority Setting

https://shotcut.org/blog/new-release-220130/
https://forum.shotcut.org/


This option removes all the entries in the Recents panel every time you cleanly exit
Shotcut (not if it crashes). This prevents other users on the computer from seeing
what you were working on.

There is also a command line option --clear-recent  that triggers this.

Settings > Clear Recent on Exit

https://forum.shotcut.org/


If you don’t see the Playlist panel in your interface, to open it you can either

Use the Ctrl + 6  keyboard shortcut ( command + 6  on MacOS)
Click on the Playlist icon on the top toolbar.
Open the View menu and click on the Playlist option.

The Playlist is a panel in the Shotcut interface where you can create a list of media
files (such as video or audio clips) to be used in your project. This playlist panel
allows you to easily organize and manage the media assets you plan to use in your
editing timeline. You can add media files to the playlist, reorder them, and preview
them before adding them to your project timeline for editing. This feature provides a
convenient way to manage your media assets and streamline your editing workflow
in Shotcut.

In Shotcut, the playlist feature can also be utilized independently of the timeline.
This means you can use the playlist to organize and manage media files for
projects that don’t necessarily require a timeline-based editing approach (see
Editing and Exporting in the Quick Start Guide). This flexibility allows users to
leverage the playlist functionality for various editing needs beyond traditional
timeline-based editing.

About the Playlist

https://forum.shotcut.org/t/quick-start-guide/12977#editing-4
https://forum.shotcut.org/t/quick-start-guide/12977#exporting-5
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Slideshow Generator makes it easy to add more than one image or clip to the
timeline and automatically:

fill the frame,
make a smooth zoom animation for still images, and
add a transition between each item.

Steps to Follow

1. Open the Playlist panel
2. Add your selected images
3. Drag within Playlist (or use sort in its menu) to the desired order

4. Select the images or videos to add to the slideshow: hold Shift  to select a

range or Control  ( Command  on macOS) to select individually
5. Click the menu button at the bottom of the Playlist panel 
6. Choose Add selected to Slideshow
7. The Slideshow Generator dialog opens

8. Adjust the settings and click OK

Playlist > Slideshow Generator

https://forum.shotcut.org/uploads/default/original/2X/b/b2b50ca2efa2e7f6a8fbab099e6f5d27eadb278a.jpeg
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9. Your images are added to the current track on the Timeline (a video track is
added automatically if it was empty)

Suggestions

Image duration only applies to still images and Audio/Video duration applies
to everything else. Audio/Video duration defaults to 4 hours until you change it.
Shotcut remembers the last value you used and defaults to that next time.
Audio/Video duration still respects the source duration and its in & out points;
duration here is a maximum.
After it creates use the usual timeline editing methods to adjust the images and
durations as required.
If trying to fit a number of slides to an existing audio track:
Estimate the slide duration (Length of track / number of slides) and use this in
the add dialog. If its too short or long, undo and repeat with a modified timing.
Adjust the duration of the first or last clips for small adjustments.
Set Zoom effect to 0 to turn it off. This is advised if most of the clips are videos
or music.

Ideas

Show off holiday or travel photos.
Create a video montage.
Make a video loop for an information screen.
Use music files and set Audio/Duration duration very high to make a music
bed track that cross-fades between each song.

https://forum.shotcut.org/uploads/default/original/2X/f/f40cec1185bd4f318a219dda8fbfafbe9a3b6a0a.jpeg


When we write about the “player” in Shotcut, we are taking about the part that looks
like below.

When you open a media file (or generator or device in Open Other), it opens in the
Source player. It is called “Source” because it can be the source of edit operations
in the Playlist or Timeline. The Project player is the preview and playback
controls for the Timeline (or Playlist if you are not using the timeline or for
advanced users).
"Open” can be any of:

File > Open
File > Open MLT XML as Clip
File > New generator or New Generator on the main toolbar
double-click a non-project (not .mlt) file in Recent or Files
double-click or drag-n-drop a Playlist item
drag-n-drop a non-project file from outside Shotcut to the player

Source is also a Shotcut clipboard viewer. Whenever, you Copy or Cut a single
clip in the Timeline, it is also put into the Source player. That way you can use
drag-n-drop or any timeline editing operation to place the clipboard contents into
the timeline–not only Paste but also Append and Overwrite. Likewise, as
mentioned above, you can add the Source clip to the Playlist.

While all other parts of the UI are panels that can be moved or made to float in a
separate window, the player cannot currently. Also, currently, the two players are
only available as tabs and not side-by-side like some other video editors. You can
adjust the size, however, by adjusting the surrounding panels and the size of the
main Shotcut window.

Source vs. Project Player

https://forum.shotcut.org/uploads/default/original/2X/b/bc26bef4acf891392e12eec8f69704caa7deb23c.jpeg
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The Loop feature was introduced in Shotcut version 24.01.28

Introduction
The Shotcut preview player has a loop feature that allows the player to loop around
a region when it reaches the end.

Enabling Looping
The loop mode can be accessed from the Player menu

It can also be accessed by clicking on the loop button in the player controls

When looping is enabled, the loop button in the player controls will be highlighted

Click the loop button again to disable looping

When player looping is enabled, a highlight region appears in the player timeline to
show the looping area

If the looped region is in the timeline, then the highlight will also appear in the
timeline ruler

Player > Loop

https://github.com/mltframework/shotcut/releases/tag/v24.01.28
https://d2t917e3b1b2xy.cloudfront.net/original/3X/e/a/ea0fdf83f5c76c786231202899ff0fb26a0e169e.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/5/f/5fb7975e14666442255a099ebe660d7e6452f6e8.png
https://forum.shotcut.org/


Loop Ranges
Shotcut provides the following options to select the region to be looped:

Loop All - loop the entire clip or timeline (depending on what is selected)
Loop Marker - loop around the area specified by a range marker that is currently
under the cursor. If the cursor is not under a range marker in the timeline, this
option will not work.
Loop Selection - loop around the selected clips in the timeline. If no clips are
selected in the timeline, this option will not work
Loop Around Cursor - set a loop that starts one second before the current cursor
position and ends one second after the current cursor position

https://d2t917e3b1b2xy.cloudfront.net/original/3X/b/1/b162eadbb6d3b6c883bb67b3f44efba669dde68d.png


The Timeline is the core of the Shotcut editing workflow. It is a multi-track, non-
linear editing area where you arrange your media clips, apply transitions, and mix
audio to create your final project. Unlike the Playlist (which is a simple list of files),
the Timeline allows for complex layering and precise timing of video and audio
elements.

Opening the Timeline
If the Timeline panel is not visible in your interface, you can open it using any of the
following methods:

Keyboard Shortcut: Press Ctrl + 5  (Windows/Linux) or Cmd + 5  (macOS).
Toolbar: Click the Timeline icon on the top main toolbar.
Menu: Go to View > Timeline.

The User Interface
1. Tracks

The Timeline is divided into horizontal rows called tracks.

Video Tracks (V1, V2, etc.): Used for video, images, and transparent
generators. Higher tracks (e.g., V2) will overlay tracks below them (e.g., V1)
based on the Blend Mode (default is “Over”).
Audio Tracks (A1, A2, etc.): Used for music, sound effects, and voiceovers.
Track Header: Located at the far left of each track. It contains controls to Mute
(audio), Hide (video), and Lock (preventing any edits to that track).

While some video editors have somewhat complicated “arm” or “record” toggles on
tracks, Shotcut simply has the concept of a current track, which has a gold color
background. This sets the target for various operations. Clicking or selecting a track
head or clip changes the current track automatically. There are also convenient
keyboard shortcuts Ctr + Alt + Up  or + Down .

2. The Playhead

The vertical white line with a “head” at the top indicates the current frame being
shown in the Project Player. You can move the playhead by clicking on the time
ruler at the top or by dragging the playhead itself.

3. Timeline Toolbar

About the Timeline
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The icon at the far left is a menu button. Click it to browse all of the possible
Timeline actions. The rest of the toolbar contains a subset of these:

Cut (scissors): This copies the the selected clip(s) to the clipboard, then
removes them including the space they occupied, and moves all of the following
clips to the left (ripple).
Copy (2 pages):** This copies the selected clip(s) to the clipboard. If only one
clip is selected it is also in the Source player if you switch to it because the
Source player in Shotcut is also an internal clipboard viewer.
Paste (clipboard icon):** Insert the clip(s) in the clipboard memory at the current
playhead time position on the current track.
New Generator (plus document icon): Opens a menu to insert a synthetic clip
to an empty or new track at the current playhead. A generator or synthetic clip
are things like text, solid background color, simple beep sound, or even a new
drawing or 2D animation you can make with the bundled Glaxnimate app!
Append (+): Append the current Source clip to the end of the current track.
Ripple Delete (-): Remove the selected clip and moves all of the following clips
to prevent a gap.
Lift (^): Removes the selected clip(s) but leaves a gap.
Overwrite (v): Adds the current Source clip to the current track at the playhead
but will not move anything out of the way or move any clips.
Split (][): Slices the selected clip at the playhead position. If no clip is selected, it
uses the clip on the current track. If there is no clip on the current track, it looks
for the topmost clip.
Marker
Previous Marker (<)
Next Marker (>)
Snap (magnet icon): When enabled, clips will “stick” to the edges of other clips
or the playhead for precise alignment.
Scrub (spaceship icon): Allows you to hear audio while dragging the playhead.
Ripple (circles icon): When enabled, moving or trimming a clip will cause all
subsequent clips on that track to shift accordingly.
Ripple All Tracks (circle with * icon): When enabled, rippling affects clips
across all tracks to try to keep things synchronized. Be careful with this! It often
causes undesirable or unexpected changes. Therefore, we recommend to leave
it off and turn it on only for possibly a single or short series of operations.
Ripple Markers (circle with bookmark icon): When enabled and an action
causes clips to ripple, also move the markers after the start of the clip.
3 buttons and a slider to Zoom in and out the timeline.
Record Audio (microphone icon): Start recording audio at the current
playhead on an empty or new audio track. This is especially useful for making a
voice-over (narration or spoken word).

Basic Operations
Adding Media



1. Drag and Drop: Drag a clip directly from the Playlist or the Source Player onto
a track.

2. Append (A): Adds the clip from the Source player to the end of the track.
3. Overwrite (B): Places the Source clip on the timeline, covering any existing

media.
4. Insert (V): Places the Source clip and pushes existing media forward to make

room.

Trimming and Moving

To Move: Click and drag the center of a clip.
To Trim: Hover over the left or right edge of a clip until the cursor changes, then
drag to shorten or lengthen the clip.

Creating Transitions

To create a transition (such as a cross-dissolve), simply drag one clip so that it
overlaps another clip on the same track. A “transition object” (marked with an ‘X’)
will appear in the overlap area. You can select this object and use the Properties
panel to change the transition type (e.g., Wipe, Iris, or Clock). You can use
trimming to create a transition by dragging the start or end of a clip across a
neighboring clip.

Advanced Controls
Track Operations: Right-click the track header area to add new tracks, delete
tracks, or change track height.
Output (Master) Track: The very bottom header labeled “Output” allows you to
apply filters (like a watermark or color correction) to the entire project at once.
Zooming: Use the slider at the bottom right of the timeline, or the keyboard
shortcuts +  and - , to zoom in for detail or out for a project overview.

Common Keyboard Shortcuts

Action Shortcut

Append to Track A

Split at Playhead S

Lift Z

Ripple Delete X

Copy C

Insert V

Overwrite B

Zoom In / Out + / -
Fit Timeline to Screen0 (zero)



Shotcut supports standard clipboard operations for managing clips on the Timeline.
These functions allow you to move media between tracks, duplicate clips, or
transfer media from the Source player into your project.

Track Selection
Before performing any clipboard operation, you must ensure the correct track is
selected.

The current track is highlighted in the Track Header (gold colored background).
Paste operations will always occur on the current track at the position of the
Playhead.

Copying Media
Copy ( Ctrl+C  / Cmd+C ) places a reference of the selected clip or transition onto the
clipboard.

You can copy a clip from the Timeline to duplicate it elsewhere.
You can copy a clip from the Source Player to prepare it for insertion into the
Timeline.
Note: Copying a clip also copies any filters applied to that specific clip instance.

Cutting Media
Cut ( Ctrl+X  / Cmd+X ) removes the selected clip from the Timeline and places it on
the clipboard. Cut is a ripple action: it automatically shifts all following clips on that
track to the left to close the gap.

Pasting Media
Paste ( Ctrl+V  / Cmd+V ) places the contents of the clipboard onto the selected track
at the playhead’s current position. This too is a ripple action: it inserts rather than
overwrites.

Timeline Toolbar Icons
While keyboard shortcuts are recommended for speed, these actions are also
available as icons on the Timeline toolbar:

Cut: Represented by the “scissors” icon.

Cut, Copy, and Paste Editing
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Copy: Represented by the “two pages” icon.

Paste: Represented by the “clipboard” icon.

Advanced Paste: Append, Overwrite, and Replace
While standard pasting ( Ctrl+V ) is useful for general movement, Shotcut provides
three “Advanced Paste” operations that offer more surgical control when moving
media from the Source player (or the clipboard) onto the Timeline.

Append (A): the fastest way to build a rough cut. Instead of worrying about
playhead placement, this command ignores the current playhead position and
places the clip at the very end of the current track.
Overwrite (B): places the clip at the current playhead position, covering any
media already on that track for the duration of the new clip. It does not shift any
other clips on the timeline (regardless of Ripple settings). It acts like laying a
new piece of physical film directly on top of the old one, “eating” into the existing
footage.
Replace (R): is a specialized tool used to swap an existing clip on the Timeline
with a new clip from the Source player while preserving the exact duration and
position of the original clip.
Select a clip on the timeline, open a new clip in the Source player, adjust its IN
(starting) point, and press R . The timeline clip is swapped out. If the new clip is
longer, it is automatically trimmed to the same duration. If the new clip is shorter,
the replaced clip is shorter and either leaves or extends a gap.
Best used for swapping out a placeholder or temporary clip for a final version, or
updating a clip while keeping all applied filters and transitions intact.

Summary of Shortcuts

Action Windows/Linux macOS

Cut Ctrl + X Cmd + X

Copy Ctrl + C Cmd + C

Paste Ctrl + V Cmd + V

Append A A

OverwriteB B

Insert V V

Replace R R



Output appears above the track headers in the Timeline:

(In versions before 20.06, this was named “Master.”)

Output refers the sum total output of the timeline - all tracks mixed (audio) and
blended or composited (video). If your clips are the inputs to the timeline, this
represents the output. It is very similar to the master output on audio mixing
consoles. You can click this to select it and then see Properties of the timeline
(the attributes of your project’s Video Mode) or Filters that affect the entire timeline.
When you have added a filter to Output, a funnel icon (same as the main toolbar
icon that opens the Filters panel appears in its block:

Often when people report all their video is black or shifted or all their audio is silent
or too loud, they have added a filter on this accidentally and forgot about it.

Timeline > Output

https://en.wikipedia.org/wiki/Mixing_console#Master_output_controls
https://forum.shotcut.org/


Ripple All Tracks has the icon  in the Timeline toolbar and menu. Here is

how it works:

Only applies when ripple mode (Ripple trim and drop) is also on: 

Or when using an edit operation that ripples: Cut or Remove (Ripple Delete).
Only affects the clips after the moved clip on the same track.
Affects footage after the original start position of the moved clip on other tracks
(I use the term “footage” when I mean there is a time range and not strictly
whole clips, and that often includes a split.)
When moving a clip right-to-left it simply pushes including a split on another
track per the moved clip’s original start position.
Moving left-to-right is more complicated and usually has 2 actions:

1. Remove the footage from the moved clip’s original start-to-end positions
including other tracks.

2. Insert the moved clip to the new position, which shifts the clips on the same
track to the right but also shifts footage on other tracks the same duration equal
to the moved clip’s duration.

The keyboard shortcut is Ctrl + Alt + R  ( option + command + R  on
macOS).

Timeline > Ripple All Tracks

https://forum.shotcut.org/t/glossary-terminology/12413#p-39168-ripple-21
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Description
The Nudge tool lets you make precise adjustments to the position of a clip in the
Timeline without having to rely solely on dragging with the mouse, which can
sometimes be challenging. Each nudge moves the selected clip one frame to the
left or to the right.

Introduced in Shotcut version 24.01.28.

How to use
There are three ways to access the Nudge tool:

TIMELINE MENU

Select a clip in the Timeline
Go to: Timeline menu > Edit
Click on Nudge Forward or Nudge Backward

RIGHT-CLICK

Right-click on a clip in the Timeline
Click on Nudge Forward or Nudge Backward

KEYBOARD SHORTCUTS
This is the most efficient way to use the Nudge tool.

Select a clip in the Timeline
Press the ,  (coma) keyboard key to nudge the clip to the LEFT
Press the .  (dot) keyboard key to nudge the clip to the RIGHT

(Animated GIF - Click on the image to begin playback)

Examples
The Nudge tool is especially useful when precise alignment between a clip and a
specific moment on an audio waveform is needed.

Timeline > Nudge

https://shotcut.org/blog/new-release-240128/
https://forum.shotcut.org/


(Animated GIF - Click on the image to begin playback)

It is also very handy when you need to move a clip in a cluttered timeline.

(Animated GIF - Click on the image to begin playback)

Limitations
The Nudge tool will not work when multiple clips are selected.
You cannot nudge a clip located at position 00:00:00:00 on the timeline.
It will not work on a Group of clips.
You cannot use the Nudge tool to create a transition.

Nudging multiple clips
While you can’t use the Nudge tool when multiple clips are selected, if you enable
Ripple or Ripple + Ripple All Tracks you will be able to nudge multiple clips.

When only Ripple is enabled: The selected clip and ALL subsequent clips on the
same track will nudge.
When Ripple and Ripple All Tracks are enabled: The selected clip and ALL
subsequent clips in the Timeline will nudge. Be cautious, however. Depending
on the position of the selected clip, with Ripple All Tracks enabled, you run the
risk of splitting the clips on the tracks above and/or below.



(Animated GIF - Click on the image to begin playback)



Markers are like time-based bookmarks for your project to help you remember and
quickly go to sections.

Timeline Markers were added in version 21.10.31.

Press M  or click toolbar button the first time to add a marker at the playhead
(current position) with no dialog.

Markers appear in the time ruler/track/row at the top of the Timeline.
Drag a marker to move it.
There are several ways to seek to a marker: Click directly on a marker, press
<  or > , or click the seeking buttons on the timeline toolbar.

If snapping is turned on then dragging clips or their edges snaps to markers and
dragging markers snaps to clip edges or the playhead.

Press Alt + R  ( option + R  on macOS) or click on the Ripple timeline
markers with edits button on the Timeline toolbar to have the timeline markers
shift according to the direction that the clips are dragged to in the timeline. Also
works in conjunction with either or both of the other two ripple functions (Ripple
trim and drop and Ripple edits across all tracks). Press Alt + Shift +
R  ( option + Shift + R  on macOS) to turn on and off all three ripple

icons at the same time.

Click toolbar button or press M  when the playhead is on the exact start time of
a marker to open the Edit dialog where you can change the name, color, start,
and end times.

Timeline > Markers

https://forum.shotcut.org/


A color change is remembered for all new markers until a new color is chosen.
Right-click a marker to open its context menu to Edit, Delete, Choose Color…,
or Choose Recent Color.

Press Ctrl + Shift + M  when the playhead is on the exact start time of a
marker to Delete it.
Ctrl +drag ( command  on macOS) a marker to changes its duration (a

marker with a duration longer than 1 frame is also called a “range”).
When the mouse cursor is over a marker then a tool tip appears with the name
and time. If the marker is longer than 1 frame (range) then the tool tip will also
show its end time and duration.

View > Markers or press Ctrl + Shift + 6  ( shift + command + 6
on macOS) to open the Markers panel where all markers are listed and can be
categorized by several columns (Color, Marker, Start, End, and Duration).
Clicking on a marker in the list will seek to that marker in the timeline. Click on a
column header to change a column’s sorting to be either ascending or
descending. Under the markers list there are buttons to Add a marker, Remove
the selected marker and Deselect the marker. Click on the hamburger menu
to Remove All Markers and to remove or add any of the columns. A search bar
is also available to filter the list by name. The rest of the panel offers the same
options as the Edit dialog for markers in the timeline where the name, color,
start, and end times can be changed.



Export > From lists all range markers (duration longer than 1 frame). Selecting
a marker here allows the exporting of just that section of the timeline.

File > Export > Markers as Chapters… outputs a .txt file in the format used to
make chapters for YouTube. Only timeline markers with a duration of 1 frame
(default) are exported as chapters.

Markers are saved to the project file in a XML tag named <properties 
name="shotcut:markers"> .
Marker operations support Undo and Redo.



1. Setting your microphone: (This only needs to be done once for Shotcut on
Windows or macOS)
Open Other - Audio/Video Device or Settings > Audio/Video Device…

Click on Open

2. Move the Timeline play head to the time where to start the recording.

3. Click Record Audio (microphone icon) on the Timeline.

4. If you did not create a project folder using New Project > Start a file save dialog
appears to name the audio file. Click Save for the file name.

5. It uses the current track if it is an audio track and empty at the play head and
beyond. Otherwise, it adds an audio track.

6. Recording starts

7. During recording the project plays without audio and shows a growing audio clip.

8. When done, click Record Audio again to stop recording.

Timeline > Record Audio / Voice-over

https://d2t917e3b1b2xy.cloudfront.net/original/3X/6/6/665f301644268a54cb8382ae90ffed8f0a8b94de.png
https://d2t917e3b1b2xy.cloudfront.net/original/3X/7/a/7a3b5958c4b4391b599fddcde3d0d15557c6fe32.png
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The Align To Reference Track tool allows multiple clips to be aligned to the audio in
a reference track. This can be useful to align clips that were recorded at the same
time from multiple camera angles.

Align To Reference Track was added in version 22.06.23.

Limitations
This tool can only be used to align clips with audio that is similar to the audio in
clips on another track. Both the clip to align and the reference track must have
audio that is similar so that the algorithm can detect the alignment.
The tool does not use timecodes for alignment

Usage
Place clips with similar audio on separate tracks. For example, put all the clips from
each camera source on its own track.

Choose one track to be the “Reference Track”. Typically, this will be the audio from
the best audio source. For example, use the camera that had the microphone
closest to the presenter.

Select the clips to be aligned (do not select any clips on the reference track)

Timeline > Align To Reference Track

https://forum.shotcut.org/uploads/default/original/3X/5/2/52d8da9a46638b6c104ca3153a613a6dc58c38df.png
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Right-click on the selected clips and choose from the menu: More->Align To
Reference Track

In the dialog, select the reference track. Then click “Process”

If the results look good, click “Apply”.

https://forum.shotcut.org/uploads/default/original/3X/7/3/7314410f00dcce77e9183a9178dd8cc6a4c37d17.png
https://forum.shotcut.org/uploads/default/original/3X/3/b/3baa7043cf59d17edf89a3e3edb6573eaf217746.jpeg
https://forum.shotcut.org/uploads/default/original/3X/0/e/0e9935e987caa5ff15fae18dcac18cfcca0af35e.png


Alternatively, both “Process” and “Apply” can be run as one action by clicking
“Process + Apply”.

The selected clips will be moved on the timeline to be aligned to the reference.

Speed drift adjustment

https://forum.shotcut.org/uploads/default/original/3X/b/2/b2ced336b88e98f55aa67952135bfa62c173fdfc.png
https://forum.shotcut.org/uploads/default/original/3X/1/2/1201e8cf4b9fea9aa557f520a65075e64b1fe758.png
https://forum.shotcut.org/uploads/default/original/3X/1/f/1fefcd99a791d43c17e6e85a9fd73d96eb64c561.png


If the selected clips can not be aligned, or if the alignment drifts over time, re-run
the tool and select “Speed adjustment range” and click “Process”. With this option
enabled, the alignment algorithm will try to detect alignment by speeding or slowing
the clips. The clip speed difference can be detected by up to +/-0.5%.

If the tool is able to detect alignment with the “Speed adjustment range” option,
after clicking “Apply”, the clips will be moved and their speed will be changed to
make the alignment.

https://forum.shotcut.org/uploads/default/original/3X/d/3/d3e052bc5816b1f388b146a394b992754b0a6078.png


The Apply Copied Filters option was added in the 24.04 release.

“Apply Copied Filters” is an option in the Timeline context menu which allows a filter
to be applied to many timeline clips at the same time. It can also be used to update
existing filters with the same value.

Applying filters for the first time
This video shows how to create a filter and then apply it to multiple timeline clips

Updating previously applied filters
This video shows how to easily modify the filter on multiple clips. First the filter is
modified on one clip. Then, the filter is copied and applied to the other clips. Note: if
the filter already exists, Apply Copied Filters will replace the filter with the new filter.
It will not add the filter multiple times.

Timeline > Apply Copied Filters

https://forum.shotcut.org/




There is a black or gray line that appears across timeline clips that have audio if
Settings > Timeline > Show Audio Waveforms is on.

Adjust the volume of a clip by dragging this line up or down. Doing so adds a
Gain/Volume audio filter to the clip’s Filters. Double-click it to reset it back to 0 for
no change (or you can remove the added filter).

Use Settings > Timeline > Adjust Clip Gain/Volume to turn this feature off.

When the line has not been moved, it represents -1 dBFS. With it you can visualize
when the audio level is dangerously close to clipping. However, keep in mind that
there can be audio clipping that occurs due to other Gain/Volume filters or mixing
with clips on other tracks.

This feature was added in version 25.07.

See also Gain / Volume Audio Filter

Timeline > Adjust Clip Gain/Volume

https://forum.shotcut.org/t/gain-volume-audio-filter/12906
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Many actions for clips in the timeline require that you select one or more of them.
There are also some actions that only work when a single clip is selected. Click the
menu button in the top left of the Timeline: there is a Selection menu.

Selected clips on the timeline have a red outline unless it is part of a group. When a
Group is selected, the clips have a white outline.

Select Single Clip
Usually, you simply click a clip with the left mouse button to select it. However, you
can also select the clip under the playhead/cursor using the keyboard combination
Ctrl + Space  ( command + space  on macOS). If there is more than one clip

under the playhead, it selects the top clip.

You can select the neighbor of a selected clip (move the selection) by holding
Ctrl  ( command  on macOS) with left, right, up, or down arrow keys.

Multiple Selection
Here are some of the actions you can perform with multiple clips selected:

Copy
Cut
Lift
Ripple Delete
Move
Split
Apply Copied Filters
Align To Reference Track

To select a range (multiple consecutive clips) click the first (or last) clip, press and
hold Shift  and click the last (or first) clip.
To select or deselect multiple clips individually hold Ctrl  ( command  on
macOS) while clicking the clips.

Rectangle Selection
You can also use the mouse to drag out a rectangle to select multiple clips. If
Settings > Timeline > Rectangle Selection is on simply click an empty area of the
timeline near a corner where you want to start. Then, holding the left mouse button
down drag to select. Release the left mouse button when you are done.

Timeline > Selection and Groups

https://forum.shotcut.org/


If that setting is turned off, hold Shift  to draw the rectangle (without Shift
clicking seeks).

To facilitate this feature, it is helpful to have empty space above or below the clips.
You can start the rectangle by clicking below the existing tracks. To have an empty
track at the top turn on Settings > Timeline > Automatically Add Tracks.

Group/Ungroup
A group is a multi-selection that is saved with the project. To make one, select
multiple clips, right-click any member, and choose Group/Ungroup from the
context menu. Alternatively, use keyboard shortcut Ctrl + G  ( command + G
on macOS). Now, whenever you click a member of a group, it selects all of the
members and show a white outline instead of red. You can have multiple groups
but not overlapping groups.

Frequently you need to work with only one member of a group. You could ungroup
and re-group later, which is tedious, or:

If the group is already selected Ctrl -click the one to use.

If the group is not selected Alt -click to select a single member of a group.

Select Track
Did you know that you can not only select clips but also a track? With a selected
track, you can add Filters to it that affect all clips on that track! There is a special
track at the top of the track headers labeled Output, and by selecting that you can
add a filter to everything in the project. However, it is better to think about that as
putting an effect between the timeline and the output–preview or the export.

However, there is also a current track. It has the gold color background. Selecting a
track or clip also makes it current, but it also possible to use the keyboard to
change the current track: Ctrl + Alt + Up  or Down  ( option + command
on macOS).

Some actions depend on the current track. See the Track Operations in the
timeline’s menu button:

Insert Track
Remove Track
Move Track Up
Move Track Down
Show/Hide
Lock/Unlock
Mute/Unmute



Use the Freeze Frame Timeline action to create an effect where the video pauses
for a short time. This is not for playback control during editing. This action was
added in Shotcut version 25.05.

To use this move the playhead (also known as the “cursor” or rather grandiloquent
“current time indicator”) to the time position where you want to hold. Then, right-
click the clip and choose Freeze Frame. This creates a one second clip with only
that frame. To change its duration, either turn on Ripple mode on the timeline
toolbar or press and hold Shift . Now, drag the right edge of the clip to adjust it.

Feel free to make your own keyboard shortcut for this action in Help > Actions and
Shortcuts.

Timeline > Freeze Frame
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In Shotcut, a transition is a specialized object created when two clips on the same
track overlap. While many video editors require you to drag an effect onto the
junction of two clips, Shotcut uses a more intuitive overlap method to create cross-
fades, wipes, and other visual transitions.

Drag and Drop

To create a transition such as a video dissolve with an audio cross-fade between
two adjacent clips on the same track:

1. Position the Clips: Place two clips next to each other on a track.

2. Overlap: Drag the second clip toward the first clip so that it overlaps the end of
the first clip.
While you are dragging, a popup appears with a time value to show you how
much you moved the clip and thus the duration of the transition.

3. The Transition Object: You will see a new rectangular object appear in the
overlap area with a purple “X” shape inside it. This indicates a transition has
been created.

4. Playback: When you play the timeline, the first clip will now smoothly fade into
the second clip.

In the screenshot above, this created a gap in the track because Ripple is off. If
you turn it on, there will be no gap and all of the clips following the clip you dragged
are moved.

Creating and Removing Transitions

https://d2t917e3b1b2xy.cloudfront.net/original/3X/c/2/c29c37d838af16e32ef02dc9661d44046976a0dd.png
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You can also drag the first clip to the right to make a transition; however, Ripple
must be off for that. Otherwise, ripple drag to the right is used to push the clips on
the track.

Trimming
Another way to make transitions if there is enough non-revealed footage before or
after the clip (due to trimming creating so-called “handles) is by trimming:

Drag the right edge of the first clip or the left edge of the second clip over the other
clip.

Adjusting a Transition
Duration: To make the transition longer or shorter, simply drag the edges of the
transition object or move the clips to change the amount of overlap.

Selection: Click the transition object to select it. When selected, it will have a
red border, and its properties will be available in the Properties panel.

Removing a Transition
Immediately after making a transition, possibly by accident, you can simply Undo
( Ctrl+Z , command+Z  on macOS). Otherwise, there are two behaviors: Lift and
Ripple Delete.

If you do not want clips to move choose Lift, the transition is removed, and each
clip is automatically trimmed to fill the gap.

If you want to retain the full duration of the clips and not change their trimming,
clips must move because two things were occupying the same space-time. Use
Ripple Delete for that.

https://d2t917e3b1b2xy.cloudfront.net/original/3X/e/6/e602f41c0c550259a9c2a62dba69361418c3e77b.png
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